Chromium browser install

Has anyone been able to install the Chromium browser onto a Raspberry Pi with DietPi V117?

I get a ‘Package has no installation candidate’ error, when I run: apt-get install chromium

Thanks,
Mark

Hi Mark,

Chromium in apt-get is only available for x32/x64 systems (not ARM): https://packages.debian.org/jessie/chromium.

It can be installed without apt-get , but you will need to follow a guide, eg: http://www.techrepublic.com/article/five-tips-for-getting-the-most-out-of-a-raspberry-pi-3-as-a-pc/

Please let me know if you experience any issues after installing Chromium using a guide.

Hi,
I’ve followed the steps in the guide, and it seemed to download & install ok. No error messages.
I now have the Chromium Web Browser program showing in the Internet menu.
However when I run it nothing happens. I see the ‘/usr/lib/chromium-browser/chromium-browser --enable-pinch’ process running in the processes list, but nothing is displayed to the screen.

Mark

A little more information…
I tried running the browser from the LXTerminal, and get the following error stack:

t@R500002:/usr/lib/chromium-browser# ./chromium-browser
[1:1:0511/140651:FATAL:setuid_sandbox_client.cc(126)] Check failed: IsFileSystemAccessDenied().
#0 0x000073cc2df2 base::debug::StackTrace::StackTrace()
#1 0x000073cd7dc6 logging::LogMessage::~LogMessage()
#2 0x0000732900c2 sandbox::SetuidSandboxClient::ChrootMe()
#3 0x000075ee597e
#4 0x000075c5eeee
#5 0x000075c5f3d2
#6 0x000075c5ebf2 content::ContentMain()
#7 0x000054d5b454
#8 0x00007217e294 __libc_start_main

Received signal 6
#0 0x000073cc2df2 base::debug::StackTrace::StackTrace()
#1 0x000073cc3128
#2 0x0000721951a0
#3 0x000072193f70 gsignal
[end of stack trace]

Not sure if this helps or not.

Mark

I have it working.
Since I was running it as root I needed to add the ‘–no-sandbox --user-data-dir’ options to the command.

Thanks for your help.
Mark