Changed to IPv6 / DS-Lite and need help

Hello there,

I changed from a DSL (IPv4) to a DS-Lite (IPv6) internet provider. Now I need some help to get my services back to work.

I use Nextcloud, Pi-VPN with Wireguard and letsencrypt on my dietpi. I used a paid hostname ( to access my old setup and it worked fine. Now I strungle with DS LIte and IPv6.

Please can someone explain to me how i get this all back to work?


If you have a prefix delegated to your lan, then the lan hosts should have a public routable IPv6 address, so you can access the devices internally directly, as long as you allow it on the router firewall.
You can no longer access the lan devices over IPv4, as the v4 traffic is getting encapsulated and NATed with CGNAT from your provider.

Ok thanks. But is there a way to get it work again? give me the option to use a AAAA hostname.

And I thought if I have ipv6 portmapping to my pi in my router activated and the address added in the loop settings this should work.

But it seems like it dose not work this way.

So I managed to get something to work.

But the connection don’t work. Over hostname and Ipv6 address. It seams to load endlessly.

I changed the


so that it says

$SERVER["socket"] == "[::]:443" {


What can I do next?

I verified that my domain “” is working. Only my nextcloud instand under does not work.

I am sorry but I am lost. I tried everything I found online and nothing worked.

All checks looked fine. But I can not access my Nextcloud over my AAAA Hostname from I don’t want so switch to an other service with cost me some money for 10% of my capacity.

Is there realy no way to get this working?

If the main domain is working, but the subdomain is not, I would check the configuration file of the nextcloud, like you did with /etc/lighttpd/conf-enabled/50-dietpi-https.conf. Unfortunately I don’t have nextcloud, so I cannot help more.

by default NextCloud is configured via sub path and not sub domain :slight_smile:

Does it work to access the domain without /nextcloud path element to access the Lighttpd example index page?