Certbot Lets Encrypt - Missing "Auto Renew" Option

Hello everybody,

i am from germany and sorry for my bad english. Linux/dietpi and raspberry is new for me.
I could not found the correct topic in the forum.

I have installed certbot and i have get the certificate. But i am missing the auto renew option.

Have any one an idea why this option is missing?

Many thanks for your help.

best regards


System: Raspberry PI 3 B+ (armv/71)/ Dietpi v6.22.3

│ [ ] 5 ALSA: linux sound system
│ [ ] 6 Xserver: linux display system
│ [ ] 17 Git Client: git clone etc
│ [ ] 73 Fail2Ban: prevents brute-force attacks with ip ban
│ [ ] 81 LLSP: lighttpd | sqlite | php
│ [ ] 84 Lighttpd: webserver
│ [ ] 87 SQlite: database│
│ [ ] 89 PHP: webserver
│ [ ] 92 CertBot: free, ssl cert install allowing https://
│ [ ] 93 Pi-hole: block adverts for any device on your network
│ [ ] 103 DietPi-RAMlog: minimal, optimized logging
│ [ ] 104 Dropbear: lightweight ssh server

The auto renewal is implemented automatically. Some time ago we had an option to toggle that but we removed that, enabling it by default, as well as this is done already by the APT package install. As long as you have CertBot installed, you want to have your certificates valid, so we believed that the choice is obsolete.

hello MichaIng,

thanks for your reply. I asked because I saw this option under the software explanation on the picture.

best regards

You can see the status of the renewal service by using

systemctl status certbot.timer

If you want to check the renewal process (it will simply tell you it is not due probably) use

certbot renew

And to force a renewal (to prove it does work)

certbot renew --force-renewal

But don’t force a renewal too often else you might hit the rate limits (assuming LetsEncrypt).