Can't seem to get remote desktop to work

Hi, I’m currently running a Raspberry Pi 3B+ with the latest DietPi version and I can’t get remote desktop to work.
I’ve installed XRDP but everytime I try to log in via Windows Remote Desktop I get this screen here:

It’s stuck like this forever, I’ve let it run for about half an hour but nothing changed, no error messages appeared.
I have also installed MATE but the screen is the same whether I run it or not, don’t actually know if I need to run it for it to work.
Not really sure what could be the problem here as I’m new to this kinda stuff.
Hope someone could help me, thanks in advance!


did you get the XRDP login screen already shown up?

Yes, I logged in successfully and after that, I get this screen

on login screen, did you select Xorg or Xvnc? Which user you are using to login?

Im using Xvnc and I’m logging in as root, but i also tried the user dietpi, same result.

did you set anything to autostart?

I tried it on my RPi3B+ and it’s working without issues :thinking:

I tried the autostart options 7 and 2, both produce the same result.
Should I try something else there?

usually autostart is not needed at all. It can stay deactivated - option 0

maybe there is an issue with tigerVNC. Do you have any VNC Viewer installed? That could be used to test the VNC Server without using XRDP.

Ok so I installed one, and it throws out an error saying the host refused the connection.
What should I do now? Sorry I’m very new to this stuff

what IP address you used to connect for the VNC Viewer? Sould be something like 192.168.0.x:1

I used which is the address of my Raspberry Pi

let’s check status of VNC Server and what port it is running on

systemctl status vncserver.service
ss -tulpn | grep LISTEN

Yup, that was the problem!
When I typed in the first command I got this response:

Not really sure why that wasn’t installed but anyways, I installed TigerVNC and now it’s working fine.
Thank you so much for helping me out!

thats strange. How did you installed XRDP? did you used dietpi-software?

No, I installed it with

$ sudo apt-get install xrdp

Was that the problem?

that’s the problem. If you would have used dietpi-software, all dependencies would be installed automatically. DietPi magic would take care on everything. :smiley:

Just running apt-get install xrdp will not pull TigerVNC. Therefore it was needed to install TigerVNC manually. :wink:

Ah alright!
Will install stuff via the dietpi-software in the future, again thank you so much for helping mate