Can't reinstall radarr using dietpi-software due to Input/Output Error

Hello everybody
i was trying to update Radarr using dietpi-software but I got into this error

Any suggestion?


many thanks for your message. Looks like you moved dietpi userdata to an external device. Could that be? And ther are I/O errors accessing this device.

Btw: to update radarr, you should use the update function inside radarr ui

The problem is that I get the same error on the web interface and that’s why I wanted to update but after updating the problem is still there

I have user data on and external HDD but Sonarr/Radarr/Transmission have no problem with access

any suggestion?

looks like it’s this specific folder causing issues. MediaCover/31

You could check for kernel messages dmesg -l err,crit,alert,emerg
Or check for file system errors fsck -a /dev/sda1 (replace /dev/sda1 with correct device name)

Here’s the result of dmesg
[ 2.936681] sd 1:0:0:0: [sdb] No Caching mode page found
[ 2.936689] sd 1:0:0:0: [sdb] Assuming drive cache: write through

So, the partition is sda3 and it’s a NTFS partition
so I should assume that NTFS is the culprit?

the kernel message is for sdb but yout device is sda. means they are not related. I don’t think it is related to ntfs as you have the error message on a specific directory. You could try to move this away. Maybe that will help.

Solved but it was tricky.
As I couldn’t delete the folder from terminal, I had to plug the hdd to my pc and manually erase it. :roll_eyes:
Thanks for your help! :wink:

ok probably some corruption on that directory. Maybe you should scan that device for errors to be on safe side.