can't login to phpmyadmin

Hi guys

I’m newbie here. I have installed DietPi on my RPi3 with LEAP + phpmyadmin but I can’t login there.
I tried user phpmyadmin with right password but I can’t. While I’m login in there is no error message only refresh login page.

Same is also if I will create new user from command line.

Thanks for help

I think the new user needs root privileges to be able to login - if you haven’t tried this do so. You cannot login as root hence need to create new user.

John

I’m not sure if I need root rights.
Then I install Adminer and there it works fine.
So probably there is problem with installation of phpMyAdmin or with settings.

Indeed the MariaDB unix_socket authentication prevents other users to login to MariaDB root user.

Thus for phpMyAdmin our install script creates a new user “phpmyadmin” with full database permissions to use for login. Password is by default the one for new software installations you were ask to change on v6.9 update.

Yes I’ve changed my password but as I said after click on login it will reload login page.

Sorry I did not read your initial post carefully. I will try to replicate later.

Could you meanwhile post results of:
tail /var/log/php7.0-fpm.log
tail /var/log/nginx/error.log
journalctl -f -t mysqld
right after login attempt? Not 100% sure about the nginx log location, in case have a look into the log directory, where exactly it is placed.

Also the browser console might give a hint. Did you try login with a different browser?

I check logs but there is nothing regarding this.
I must find where is nginx log.

Another step.
I’ve downloaded phpmyadmin from webe and after login there is message: Failed to set session cookie. Maybe you are using HTTP instead of HTTPS to access phpMyAdmin.

So problem will be with configuration of mphMyAdmin

Hmm, looks like an issue on phpMyAdmin side: https://github.com/phpmyadmin/phpmyadmin/issues/14184

But this error didn’t show up in the first place?

Did you setup HTTPS/SSL connection? It looks like there are issues, if you switch from HTTP to HTTPS and backwards, thus automated redirection to HTTPS would be needed in this case, that you cannot connect via HTTP any more, once the secure cookie was set.

Of course that means, that you could test to remove the cookies for you phpMyAdmin site and retry.
Nginx perhaps also logs to syslog/journald, you could check:
journalctl -t nginx
journalctl -u nginx

No actually I have only unsecure HTTP but under Firefox is working, only in opera it doesnt work.

Any new ideas why preinstalled phpMyAdmin isn’t working?