can't install on qnap debian VM

I tried to install dietpi on a freshly created debian10 VM running on Virtualization Station of a QNAP.
When I try to run the install script (Supported hardware - Docs) selecting master

chmod +x

I get: [FAILED] DietPi-PREP | Unknown or unsupported CPU architecture: “i686”. Aborting…

I have selected “Intel Core i7 (Westmere)” as the CPU version in the VM.

Any chance to get this installing?

Succeded in getting the script to run by changing the line and replacing x86 with i686.

But after entering name etc I got this:


i686 is not supported


if possible you would need to use x86_64 as architecture.

It’s not worth the while… Was testing. I’ll remain on the 2 pie4’s and Zotac I have running.


I wrongly donwloaded the 32bit debian CD…

Tried again with 64bit one:

Worked without a hitch!!!

Yep it would need to be 64bit image. Personally I’m running a couple of demo VM’s on my Synology NAS using the VirtualBox image.

I’ll try that image also
EDIT: installed on Qnap Vrirtual Station but didn’t boot from the disk…

on Synology I need to import the OVA file to be able to run a VM from it. Simply creating a VM is not working as well. Not sure how this is on QNAP.

That’s what I did but hangs on booting from HD.
There’s probably a way around this but as I have it running via Debian install it’s not worth digging into it.

Ok as the result is same, it doesn’t matter how you set it up. :sunglasses: