Can't enable remote access for Plex


I have a Fritz Box 7430 (not sure if that is a model number or just to differentiate it from the other boxes near me)…for the life of me, I cannot figure out how to get remote access to work on Plex. I have messed with a lot of settings on my router and last night it was working but when I turned it on, it was disabled again.

I have done some searching on the internet and on this forum and I have seen port forwarding mentioned a lot. I understand in general what that is (I’m really new to all this). THe problem though, is that there is not anything on my router that says “for port forwarding go here”,LOL.

If someone could give me some insight or a quick idiots guide on how to do this, I would appreciate it. I think I am close but there is something that I am missing…

I have a lot of my media loaded and everything runs great…at home…but being able to use this remotely is sort of the whole reason that I am trying to do this.


This has nothing really to do with DietPi. As far as your issue goes, you need to look up how to port forward for your specific router model. So you need to access your router admin panel through or something similar. As far as the login, you can probably Google the generic login either for your specific router, or for your ISP if you haven’t personally changed the login. Once you do that, look for NAT/QoS or Port Forwarding. Go through all the tabs till you find it. Then you want to port forward TCP 32400 (32400 is Plex’s default) for both to and from if your router has that option, and use the local IP address of your Fritz Box 7430. If you don’t know what it is, do ifconfig and look for inet .

Thanks, I’ll keep looking for the port forwarding area but as I said in my original post (not being snarky)…I can’t find it. But it’s gotta be there…

Well you still haven’t mentioned anything about your router at all, or what firmware it is using. I assume you have access because you’re searching through the menus. So what is your router model then? Is it using ISP firmware or not? That being said, you can just google " port forwarding" and there should be instructions.

It’s a Fritz Box 7430, although I can’t do anything for about a week (out of town).

I can get into the router and I found the area I think. They call it “port sharing” but I couldn’t make it work I didn’t have time to mess with it for very long though. I do remember not seeing “upnp” or the other option that I have read that I am supposed to use. There was GRE and some others, can’t remember now since I’m not at home.

I am looking around on the internet now for the very thing you mentioned when I remembered to come back here and check this thread.

Check this out…after my last post just now, I went to my Plex app and my dietpi server worked perfect. I don’t even know what I did, LOL. It wasn’t working when I left the house and I’m on the other side of the country now and havent changed anything.

Yeah I thought the Fritz Box was your server hardware, not the router itself. I looked at the instructions and it’s like I almost have no idea what it does. I saw the port stuff you mentioned as well. I would have dumped that router immediately lol. I looked at alternate firmware and your box doesn’t support DD-WRT either which would have made it super easy. I’m glad things worked out for you though.

I had to think about it some more then I remembered what I did (I was with friends having some beers when I posted before,lol)…

There is something on Plex, I don’t recall the name, but enabling it allows Plex to act as sort of a middle person between my phone and my DietPi server. It seems to take a little longer to get going at the beginning of a movie but other than that it was fine for me. I enabled that before I left the house and that must have worked for me. Thanks again to all for the help.