Can't connect to internet on fresh install on Raspberry PI 3 B+

So I followed the instructions to install dietpi on a brand new Raspberry Pi, and on the first boot I get this error:

unable to resolve host address ‘

It is a fresh install on a new rpi, no settings changed ANYWHERE, and the device is directly connected to my router via ethernet, so as far as I can tell there’s not much room for things to go wrong here.
Does anyone have an idea what might be going on here?

edit: I forgot to add that I did the network test on the menu trying to connect to and it failed as well.

I have the same problem here with the raspberry 4 and the last image.

I found the solution.
It seems that the problem was that my time zone was incorrect and the network adapter settings were somehow not actually existing(?)

Anyone who encounters that problem should attempt the following steps, they fixed it for me:

  1. Enter Dietpi Config
  2. Under ‘Language/Regional’ change your time zone
  3. Under ‘Network Options: Misc’ MANUALLY set the ‘Boot Net Wait’, ‘G_CHECK_URL Timeout’, and ‘G_CHECK_URL Attempts’ to whatever you want (even if you want to keep the default settings, set them up manually)
  4. ‘Under Network Options: Adapters’ test your internet connection.

Hi Koala,

What did you mean by ‘manually’ set them? I’m having the same issue, and I have tried:

  1. Opening dietpi-config
  2. Networking [Misc]
  3. Boot_net_wait set to “Off”
  4. G_CHECK_URL Timeout to 10
  5. G_CHECK_URL Attempts to 5

But still don’t have internet access even though my Pi 4 is on the LAN

UPDATE: Some more information for anyone who stumbles across this

I have fixed it by enabling wifi and rebooting (not even connecting to anything, just enabling) eth0 now works flawlessly

I just had to go to the network settings and manually connect to my WiFi. Then it worked👌