Can't change webserver preference.

Hi. I’m expecting some troubles after installing PiHole.

  1. I’m installed PiHole and all worked fine.
  2. After change from Wi-Fi dongle to Ethernet cable and executing
pihole -r

my lighttpd service died and wont work after rebot. Tried some desicions from Google, but it doesn’t help me.
3. Made

apt-get purge lighttpd

and install Nginx from dietpi-software utility. Then Web panel of Pihole and my custom index.html became reachable.
4. From then i can’t change Webserver Preference option in dietpi-software from lighttpd to Nginx. It says that preference is changed, but after relaunch of dietpi-software lighttpd still there.

How can i fianlly change it to Nginx.

Thanks in advance!

can you rollback to lighttpd? and than we could check what the issues with lighttpd are.

I dont know what it was…

I deleted Nginx and again install Lighttpd from dietpi-software utility. And all works fine :smiley: