Can't access to my RPi 3B+ with dietpi via Wi-Fi

This include SSH, pihole web interface, SFTP, sonarr, radarr, plex server, qbittorrent-nox etc. Basically everything on the Pi is inaccessible if I’m using a Wi-Fi connected device. This happened after I mounted an external drive (Why?). I tried enabling wifi on the Pi and if I’m using wifi it works (I must be connected, not only enabled). I get these errors briefly on the screen when changing network settings (not only wifi related) if wifi is off:

  • [Failed] An interface of type “wlan” does not exist.
  • n180211 not found.

Ethernet works no problem.

just to sumarize it for myself. Do I understood correctly, your Pi is connected via Ethernet and you have issues to connect if your client is connected via WiFi. A client connected via Ethernet is able to connect. And the other way around, if your Pi is connected via WiFi, your WiFi clients are able to connect.

Yes, exactly. But if my Pi is connected via WiFi my ethernet client IS able to connect to Pi. Real strange…

Looks like something on your local network is blocking access from WiFi to Ethernet. I don’t think this is an issue of DietPi. Because DietPi or your Pi don’t know how the client is connected.

Do you use the same network segment on Ethernet and WiFi? Or do you use any guest WiFi with special settings? Did you tried to use a different access point? Maybe some special settings on your router?

Yes I think the router did something on his own because after further testing I tried to assign a static ip adress with WiFi and the Pi is not accessible from my network anymore. I’ll try to reboot the router

Rebooting the router fixed it.