can't access pihole admin over local network [SOLVED]

I have a dietpi nextcloud and pihole server setup on a lighttp web server. I installed letsencrypt to use SSL certificates. I can access the nextcloud server using my external dns address over https, but I am unable to get to the pihole admin “https://raspberrypi.local/admin”. Safari reports
Safari can’t open the page “https://raspberrypi.local/admin/index.php” because Safari can’t establish a secure connection to the server “raspberrypi.local”. And yes, raspberrypi.local resolves to my local IP address.
I think i remember a setup screen asking if i wanted to block local access and I hit yes. Or was that blocking WAN access?? Is there any way to get back to that and reset it? Which config files do I need to look at?
I found this thread that sounds like what is happening, but I don’t know which config file they are looking at.

Any help would be appreciated, Thanks!


if I’m not mistaken this is a security feature of Safari, preventing you to access a web site via https where the certificate did not match the url you have entered.

You are trying to access raspberrypi.local while the SSL certificate was issued on your external domain, most probably.

Why are you not using your external domain to access your system, even if it is locally, like ?

Wow, Thanks. That worked. I swear I had tried that, but I must not have. I guess i wasn’t trying that because I had blocked the access to the admin from external interfaces. I just tried to access it on my cell phone, and it gave me a “403 forbidden” so I guess everything is OK.