Can't access DietPi after Latest update

  • DietPi version | Latest
  • Distro version | ARMBIAN
  • SBC model | `RockPi4
  • SD card used | eMMC

I have recently successfully updated to Bullseye.
Today I ran dietpi-update because it was recomending it.
After the update it wanted to restart but I couldn’t connect on SSH. I saw that the SBC wasn’t getting an IP address on my router. I then tried to view it from the HDMI connected to my TV but the TV got no signal from the HDMI port that my RockPi4 was connected to. I then installed a fresh image on the eMMC. It then boots up and I can access both SSH and on the HDMI. It then goes through all the steps of a fresh install and asks to reboot. Then BAM can’t get in from HDMI or SSH because no IP address gets assigned. It is connected via LAN cable.

Any help is appreciated

I guess like this one. Issues updating to 8.10 on Rockport64 board that was running fine · Issue #5845 · MichaIng/DietPi · GitHub

Indeed a bug in the latest Armbian rockchip64 kernel: Rock pi 4B boot failed after update - Beginners - Armbian Community Forums
Upgrade has been disabled, I guess taken down from the repo. So reflashing should now work.

1 Like

Thanks so much @MichaIng. I will reflash.