Cannot boot - LD_LIBRARY_PATH issue

My rpi had been working well for a while. I wanted to restart a service. I got “error while loading shared libraries: cannot open shared object file” error. Then I tried $LD_LIBRARY_PATH command and it returned nothing. I tried to export but again $LD_LIBRARY_PATH but it returned nothing again. So I turned it off and on again. Now I am getting the same error during boot. What should I do? I think I have to set LD_LIBRARY_PATH variable but I dont know how.


can you check installation status of libuuid1

dpkg -l | grep libuuid1

If it is already installed, you could try to reinstall

apt install --reinstall libuuid1

btw: what is the service you try running?

To set a variable you could do following

  1. Go to the home folder and edit .profile
  2. Place the following line at the end
export LD_LIBRARY_PATH=<your path>
  1. Save and Exit.
  2. Execute this command
sudo ldconfig

Hello Joulinar , thank you for fast response.
Unfortunatelly My rpi is not booting any more so I can’t enter ant command.

to bad, maybe something more broken on your device/SD card