Can’t start a physical desktop with lxde

  • DietPi version

  • Distro version

  • Kernel version
    Linux DietPi 5.10.0-20-amd64 #1 SMP Debian 5.10.158-2 (2022-12-13) x86_64 GNU/Linux

  • SBC model
    Native PC (x86_64)

Hello everyone.
I have recently reinstalled dietpi on my PC and I am unable to start a physical desktop.
I have installed lxde via dietpi-software. I have a mouse, keyboard and physical monitor connected via HDMI. Before reinstalling, with the same hardware I could start a desktop with the “startx” command but after doing a clean install I can’t.
i tried
-with root user and Dietpi
-I have tried two different HDMI cables

Can you help me? I am a fairly new user
Thank you

  • I attach the log file xorg.0.log

Xorg.0.log (5.3 KB)

I’ve testet the setup on several PC’s with a fresh DietPi installation and a lxde desktop without any issues. Did you install the bios or uefi image?

I have used the uefi image.
I’ve running Dietpi with this hardware for two years. But now, with the fresh installation I can’t start the desktop (or maybe I don’t remember what I did to configure it two years ago :man_shrugging: )

I see following error message within the log

[  2940.652] (EE) Failed to load module "fbdev" (module does not exist, 0)

Could you try following?

apt install xserver-xorg-video-fbdev

Yes!! It’s works! But only with root.
Now I can’t start with dietpi user.

For user dietpi you might need to add them to video group. Otherwise desktop can’t be started.

Thank you very much!!!