Can only access DietPi on SSH all other access blocked after fresh install

Creating a bug report/issue

I have searched the existing open and closed issues

Required Information

  • Distro version | bookworm
  • Kernel version | Linux DietPi 6.6.16-current-rockchip64 #1 SMP PREEMPT Fri Feb 23 08:25:28 UTC 2024 aarch64 GNU/Linux
  • Architecture | arm64
  • SBC model | ROCK 4 (aarch64)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | eMMC

Additional Information (if applicable)

  • Fresh install of the latest bookworm image

Steps to reproduce

  1. After a fresh install I configured my NordVPN settings with the killswitch enabled and connected the VPN
  2. I installed Samba Server and Sonarr
  3. I tried to access the Samba share from my laptop with \<DietPi.IP address>\dietpi but it says the share is not available
  4. Acessing Sonarr’s webpage http://<DietPi.IP>:8989 says the site cannot be reached
  5. I disconnected the VPN and Samba and sonarr is still not accessible and internet access is offline
  6. I disabled the killswitch in the VPN and with the same results
  7. I am still able to SSH into my DietPi

Expected behaviour

  • I should be able to access the DietPi through other means other than SSH
    with the VPN connected or disconnected or killswitch disabled. And I should be able to connect to the internet with VPN disconnected and killswitch disabled.

Actual behaviour

  • Only SSH access is allowed with or without VPN/killswitch and no internet connection if VPN is disconnected with killswitch disabled.

Extra details

Did you reboot the system after VPN has been enabled? Maybe some iptable rules are active still

And yes, killswitch is blocking everything access except SSH.

Hi Joulinar.
Yes, I restarted multiple times. I disabled the killswitch and still can’t access the dietpi (only SSH) or have internet connection. The internet only works when the VPN is running.

VPN connected + killswitch disabled = Access to internet / SSH access but no web access or Samba
VPN disconnected +killswitch disabled = No internet access / SSH access but no web access or Samba

It started working again. I enabled the killswitch and disabled it again. Now it seems to be working.