Can not enable wifi

I had install Dietpi V6.7 in the TinkerBorde. But I can not enable wifi. I use the dietpi-config command to start WiFi. It will return to the error prompt :
Error for wireless request “Set Power Management” (8B2C) :
SET failed on device wlan0 ; Operation not permitted.
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlan0

I can confirm this bug. I just downloaded and installed new image of Dietpi to my Tinker Board and I am having same error. Few months ago I had same problem but I resolved it by using image given by Fourdee here Upgrades to new versions worked fine but now I had to download new image and I have same problem.

At first boot I can get working wifi by using dietpi-config but after boot wifi is not working any more and there is no way to enable it. I am unable to replicate this every time (on multiple installs I have done). Error is the same as described by ewalker.

I will try to do some debugging at weekend when I have more time and do better bug report.

Thanks for the report. We’ll open a ticket for investigations.

Looks like same shit again. Now wifi is working for first boot but after automatic update wifi is not working.
Works in 6.7 image and not working after update to 6.8.