C4 does not reboot after last update


All worked well untill last upgrade 8.9.1 ->8.9.2.
Now when I want to reboot, it is cutting connection, but now starting again (only red led on). I need to power cycle (which is not convenient as I need to get to well hidden shelf).

Any idea what went wrong?

root@DietPi:~# ls -la /boot
total 82088
drwxr-xr-x  4 root root     4096 Oct 10 08:31 .
drwxr-xr-x 18 root root     4096 Oct  6 20:25 ..
-rw-r--r--  1 root root        0 Oct 10 07:44 .next
lrwxrwxrwx  1 root root       24 Oct 10 07:44 Image -> vmlinuz-5.10.144-meson64
-rw-r--r--  1 root root  5333621 Sep 21 20:02 System.map-5.10.144-meson64
-rw-r--r--  1 root root     3013 Aug 28 22:51 boot.cmd
-rw-r--r--  1 root root     3085 Aug 29 18:34 boot.scr
-rw-r--r--  1 root root   229150 Sep 21 20:02 config-5.10.144-meson64
drwxr-xr-x  4 root root     4096 Oct 10 08:32 dietpi
-rw-r--r--  1 root root    18092 Aug 28 22:51 dietpi-LICENSE.txt
-rw-r--r--  1 root root    15251 Aug 28 22:51 dietpi-README.md
-rw-------  1 root root     3950 Aug 29 18:40 dietpi-wifi.txt
-rw-r--r--  1 root root    16013 Oct 10 08:31 dietpi.txt
-rw-r--r--  1 root root      343 Aug 29 18:40 dietpiEnv.txt
lrwxrwxrwx  1 root root       20 Oct 10 07:44 dtb -> dtb-5.10.144-meson64
drwxr-xr-x  4 root root     4096 Oct 10 07:43 dtb-5.10.144-meson64
-rw-r--r--  1 root root 12667545 Oct 10 07:45 initrd.img-5.10.144-meson64
-rw-r--r--  1 root root 26530368 Oct 10 07:44 uImage
lrwxrwxrwx  1 root root       24 Oct 10 07:45 uInitrd -> uInitrd-5.10.144-meson64
-rw-r--r--  1 root root 12667609 Oct 10 07:45 uInitrd-5.10.144-meson64
-rw-r--r--  1 root root 26530304 Sep 21 20:02 vmlinuz-5.10.144-meson64

Did you recall what kind of apt packages has been updated before? Was there a kernel update?

I do not remember. sorry.

I remember some issue with kernel on C2/C4 Odroid C2 | Does not boot on reboot without power cycling · Issue #5414 · MichaIng/DietPi · GitHub

Can you try to flash the new bootloader:

. /usr/lib/u-boot/platform_install.sh
write_uboot_platform "$DIR" "$(lsblk -npo PKNAME "$G_ROOTFS_DEV")"

Copy&paste this code, note the space between dot and path of the first command, which is required (the script is “sourced”).

I did it but it was so quick or nothing happened when I pressed enter straight away new prompt appeared but there was no error either but still no reboot, It needs a power cycle.

Ok so I flashed Armbian Jammy and reboot worked. I did apt update, upgrade and there was kernel upgrade too, and reboot is not working, again.

I tried nand-sata-install → “Update bootloader” but that did no worked and still no reboot. This is what Armbian suggested. And as their support is weak I’m stuck.

Anyway my idea was that it might happened here the same alonge the update it was kernel update and this screwed reboot. Maybe this will give idea how to fix it in dietpi at least.

Help please?

Jammy would be Ubuntu while DietPi is based on Debian. There you would need to use Bullseye.

But doesn’t matter that much in this case. As far as I know, kernel should be same.

The point is, we don’t do own kernel development as we use stock Armbian kernel for these images. I guess we are not able to work around as long as Armbian is not going to fix this.

Ohh well, thanks. It seems that we are at mercy of Armbian devs anyway. I will poke there around maybe they will fix it one day.

The kernel and bootloader on Debian and Ubuntu Armbian and DietPi images are the same, so indeed the recent kernel upgrade must have broken reboot (since bootloader is not updated/flashed automatically).

Probably we can find recent commits which may be responsible, as long as it was not a Linux upstream change.

That would be awesome, I will push Armbian devs to make this to so one day I can reboot again :wink:

Goog luck with that one. :wink:

I like mission impossible :wink: