Bullseye: Samba share not working on RPI 3B

i just did a fresh install of DietPi_RPi-ARMv8-Bullseye on a Pi 3B, installed Samba but it doesn’t seem to be working (can’t access the share from Win 10 with the dietpi u/p even after smbpasswd -a dietpi).

Am I missing something?

nano /etc/samba/smb.conf

        comment = DietPi Share
        path = /mnt/dietpi_userdata
        browseable = yes
        create mask = 0664
        directory mask = 0775
        valid users = dietpi
        writeable = yes
max connections = 8


pls can you share following

journalctl -u smbd -u nmbd

-- Journal begins at Tue 2021-08-17 22:14:08 ACST, ends at Tue 2021-08-17 22:26:50 ACST. --
Aug 17 22:14:28 Pi-2C systemd[1]: Starting Samba NMB Daemon...
Aug 17 22:14:29 Pi-2C systemd[1]: Started Samba NMB Daemon.
Aug 17 22:14:29 Pi-2C systemd[1]: Starting Samba SMB Daemon...
Aug 17 22:14:30 Pi-2C systemd[1]: Started Samba SMB Daemon.
Aug 17 22:14:56 Pi-2C smbd[1229]: pam_unix(samba:session): session opened for user dietpi(uid=1000) by (uid=0)
Aug 17 22:15:56 Pi-2C smbd[1229]: pam_unix(samba:session): session closed for user dietpi
Aug 17 22:23:01 Pi-2C smbd[1275]: pam_unix(samba:session): session closed for user nobody

Android LAN access to the Pi is fine, its just Windowz - seems that it didn’t like the ip credentials, removed and rebooted fixed it

Might need to go into the advanced network sharing on your windows machine and turn off 128bit sharing and set the 40-56 bit sharing

Also…doesn’t it need to have

browsable = yes
writable = yes
read only = no

SMB shares are always confusing for me

read only is an inverted synonym is writeable, so not required if one is already specified.