[Bug] Sonarr and Radarr not starting

The following post is not a request for help, more of an FYI for anyone experiencing issues :

I did a clean install today of the newest Dietpi image, and came to the conclusion that neither Sonarr nor Radarr (and according to some, Jacket is affected as well) seemed to work.
Tried three different SD cards before coming to the conclusion this was either an installation problem or something else, so i did some searching and came to the conclusion that i was far from alone, and that the issue was (supposedly) widespread across several distributions.

Since that seemed a bit odd, i searched again, and came to the conclusion that the problem seems to be with Mono/NLog, if posts on the Sonarr Github : click me! and a bugreport posted on Mono’s Github : Click me harder!! are to be believed.

Apt-get update currenly yields the following result :

root@*my system name here*:~# apt-get update
Get:1 http://download.mono-project.com/repo/debian stretch InRelease [5863 B]
Ign:1 http://download.mono-project.com/repo/debian stretch InRelease
Get:2 https://apt.sonarr.tv master InRelease [13.3 kB]
Hit:3 https://www.mirrorservice.org/sites/archive.raspbian.org/raspbian stretch InRelease
Hit:4 https://archive.raspberrypi.org/debian stretch InRelease
Ign:2 https://apt.sonarr.tv master InRelease
Fetched 19.2 kB in 4s (4593 B/s)
Reading package lists... Done
W: GPG error: http://download.mono-project.com/repo/debian stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A6A19B38D3D831EF
W: The repository 'http://download.mono-project.com/repo/debian stretch InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: https://apt.sonarr.tv master InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EBFF6B99D9B78493
W: The repository 'https://apt.sonarr.tv master InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

So it won’t be of much use, sadly.

Suggestions thus far seem to come down to switching back to the previous version of Mono and pinning it until this is fixed, or to wait for a fix.
Personally i’ve just installed an older version of Mono, which (for me) fixed the issue for now, but YMMV.

(side note; apologies for not (also) using GitHub to report this, i’m rather busy and couldn’t find my login info for my GitHub account :blush: )


Thanks for the report. We’ve found a git ticket with same issue, looking into it now:

watching with baited breath!!!

Hi there,
I did a new and clean install on my new odroid XU4, all went well - but Sonarr and Radarr stop working after a short time. Cannot restart webinterface. Only reboot helps, but then after a short while same thing happens again.
I wonder is it the same issue taht was posted here? I followed the link to github, seems like there is a patch, but I could not really understand if it already available on dietpi.

I am running dietpi 6.4, it seems as if the problem started after I updated to 6.4 from the downloaded image.
Radarr and Sonarr are both updated.

I uninstalled Radarr and reinstalled, this seemed to have made it better - but will check later.

I’m not a DietPi user. I found this post with an internet search.

I have been having issues with Sonarr, Radarr and Jackett crashing for a few weeks now on the XU4. I tried several versions of Mono from to (currently) I found that the earlier versions of Mono worked best, but none worked very well. Perhaps 4.8 worked better but I don’t recall.

I finally moved my installation to an Odroid C2 and things are working just fine. I think it’s an architecture issue with the XU4. I don’t want to pursue this any further because it’s really becoming a time sink.

There probably is a fix and I’m anxious to hear about it. I don’t have the skills necessary to contribute in the effort. I was spending nearly 2 hours a day on this and I didn’t get anywhere.

So you guys are not alone. Maybe you can try a Mono closer to 4.8? I think all my problems started before the new year, but I could be wrong about that. It would not be a permanent fix, merely duct tape, but it might help.


as I wrote beore reinstalling Sonarr and Radarr worked - but as of yesterday it is all over. Sonarr and Radarr stop running after a few minutes after installation. Deleting and reinstalling only helps for few minutes.

I have no idea what happened in the meantime.

Nzbget and plex are running without a problem. Odroid XU4 - I have no idea how to install an older version of Mono, as it was stated here.

Could someone please write a foolproof guide for me? Thanks.

I still hope that the issue will be fixed.


Lets check the status of the services, once they fail. Please paste results:

dietpi-services status

Uups, sorry I completely missed your reply. I meanwhile found a way to get S & R running, it still works. So this might help others with the same problem:

Uninstall Radarr & Sonarr & (most importantly) Mono.
Restart, then install Radarr & Sonaar - then it works.

Well it did work, but now stopped working again. What is wrong?

Now Sonarr stopped working…

 Mode: status

[  OK  ] DietPi-Services | cron active (running) since Thu 2018-03-29 19:22:59 C                                                                                                                                                             EST; 2min 31s ago
[  OK  ] DietPi-Services | plexmediaserver      active (running) since Thu 2018-                                                                                                                                                             03-29 19:22:59 CEST; 2min 30s ago
[FAILED] DietPi-Services | sonarr       failed (Result: signal) since Thu 2018-0                                                                                                                                                             3-29 19:24:02 CEST; 1min 27s ago
● sonarr.service - Sonarr (NzbDrone) Daemon
   Loaded: loaded (/etc/systemd/system/sonarr.service; disabled)
   Active: failed (Result: signal) since Thu 2018-03-29 19:24:02 CEST; 1min 27s                                                                                                                                                              ago
  Process: 1298 ExecStart=/usr/bin/mono --debug /opt/NzbDrone/NzbDrone.exe -nobr                                                                                                                                                             owser (code=killed, signal=ABRT)
 Main PID: 1298 (code=killed, signal=ABRT)

Mar 29 19:24:02 DietPi mono[1298]: be856000-be877000 rw-p 00000000 00:00 0                                                                                                                                                                       [stack]
Mar 29 19:24:02 DietPi mono[1298]: ffff0000-ffff1000 r-xp 00000000 00:00 0                                                                                                                                                                       [vectors]
Mar 29 19:24:02 DietPi mono[1298]: Native stacktrace:
Mar 29 19:24:02 DietPi mono[1298]: Debug info from gdb:
Mar 29 19:24:02 DietPi mono[1298]: mono_gdb_render_native_backtraces not support                                                                                                                                                             ed on this platform, unable to find gdb or lldb
Mar 29 19:24:02 DietPi mono[1298]: =============================================                                                                                                                                                             ====================
Mar 29 19:24:02 DietPi mono[1298]: Got a SIGSEGV while executing native code. Th                                                                                                                                                             is usually indicates
Mar 29 19:24:02 DietPi mono[1298]: a fatal error in the mono runtime or one of t                                                                                                                                                             he native libraries
Mar 29 19:24:02 DietPi mono[1298]: used by your application.
Mar 29 19:24:02 DietPi mono[1298]: =============================================                                                                                                                                                             ====================
[  OK  ] DietPi-Services | radarr       active (running) since Thu 2018-03-29 19                                                                                                                                                             :22:59 CEST; 2min 30s ago
[  OK  ] DietPi-Services | nzbget       active (running) since Thu 2018-03-29 19                                                                                                                                                             :22:59 CEST; 2min 30s ago
[  OK  ] DietPi-Services | dietpi-boot  active (exited) since Thu 2018-03-29 19:                                                                                                                                                             22:57 CEST; 2min 32s ago
[  OK  ] DietPi-Services | dietpi-postboot      active (exited) since Thu 2018-0                                                                                                                                                             3-29 19:22:57 CEST; 2min 32s ago

Looks like a bug in either Sonarr and/or Mono library. Could also be an issue with Mono version used (which should always be the latest available via APT) with current version of Sonarr.

Please paste results, we’ll check mono version installed:

dpkg -l | grep mono

At the moment all is ok again, what I had done was update dietpi to 6.5 and reinstall Sonarr and Radarr again.
Been running, here is all the info, hope this helps to get to the root of the problem. Yet, at the moment it works.

login as: root
root@'s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
-bash: warning: setlocale: LC_ALL: cannot change locale (0)
-bash: warning: setlocale: LC_ALL: cannot change locale (0)
-bash: warning: setlocale: LC_ALL: cannot change locale (0)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (0)
[  OK  ] Root access verified.
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (0)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (0)
 DietPi     | 15:38 | Sat 31/03/18
 v6.5       | Odroid XU3/XU4/HC1/HC2 (armv7l)
 eth0       |

 Created by : Daniel Knight
 Web        : http://DietPi.com
 Twitter    : http://twitter.com/dietpi_
 Donate     : http://goo.gl/pzISt9

 Device image possible thanks to: Meveric
 DietPi's web hosting is powered by: MyVirtualServer.com

 dietpi-launcher  = All the DietPi programs in one place.
 dietpi-config    = Feature rich configuration tool for your device.
 dietpi-software  = Select optimized software for installation.
 htop             = Resource monitor.
 cpu              = Shows CPU information and stats.

root@DietPi:~# dietpi-services status
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (0)
[  OK  ] Root access verified.

 Mode: status

[  OK  ] DietPi-Services | nzbget       active (running) since Thu 2018-03-29 20                                                                                                                                                             :20:43 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | plexmediaserver      active (running) since Thu 2018-                                                                                                                                                             03-29 20:20:43 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | sonarr       active (running) since Thu 2018-03-29 20                                                                                                                                                             :20:43 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | radarr       active (running) since Thu 2018-03-29 20                                                                                                                                                             :20:43 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | cron active (running) since Thu 2018-03-29 20:20:43 C                                                                                                                                                             EST; 1 day 19h ago
[  OK  ] DietPi-Services | dropbear     active (running) since Thu 2018-03-29 20                                                                                                                                                             :20:36 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | dietpi-boot  active (exited) since Thu 2018-03-29 20:                                                                                                                                                             20:42 CEST; 1 day 19h ago
[  OK  ] DietPi-Services | dietpi-postboot      active (exited) since Thu 2018-0                                                                                                                                                             3-29 20:20:42 CEST; 1 day 19h ago
root@DietPi:~# dpkg -l | grep mono
ii  ca-certificates-mono                                         all          Common CA certificates (Mono keystore)
ii  libmono-2.0-dev                                              armhf        Mono JIT library - Development files (Default version)
ii  libmono-accessibility4.0-cil                                 all          Mono Accessibility library (for CLI 4.0)
ii  libmono-cairo4.0-cil                                         all          Mono Cairo library (for CLI 4.0)
ii  libmono-cecil-private-cil                                    all          Mono.Cecil library
ii  libmono-cil-dev                                              all          Mono Base Class Libraries (BCL) - Development files
ii  libmono-codecontracts4.0-cil                                 all          Mono.CodeContracts library (for CLI 4.0)
ii  libmono-compilerservices-symbolwriter4.0-cil                 all          Mono.CompilerServices.SymbolWriter library (for CLI 4.0)
ii  libmono-corlib4.5-cil                                        all          Mono core library (for CLI 4.5)
ii  libmono-cscompmgd0.0-cil                                     all          Mono cscompmgd library (for CLI 4.0)
ii  libmono-csharp4.0c-cil                                       all          Mono.CSharp library (for CLI 4.0)
ii  libmono-custommarshalers4.0-cil                              all          Mono CustomMarshalers library (for CLI 4.0)
ii  libmono-data-tds4.0-cil                                      all          Mono Data Library (for CLI 4.0)
ii  libmono-db2-1.0-cil                                          all          Mono DB2 library
ii  libmono-debugger-soft4.0a-cil                                all          Mono Soft Debugger library (for CLI 4.0)
ii  libmono-http4.0-cil                                          all          Mono.Http library (for CLI 4.0)
ii  libmono-i18n-cjk4.0-cil                                      all          Mono I18N.CJK library (for CLI 4.0)
ii  libmono-i18n-mideast4.0-cil                                  all          Mono I18N.MidEast library (for CLI 4.0)
ii  libmono-i18n-other4.0-cil                                    all          Mono I18N.Other library (for CLI 4.0)
ii  libmono-i18n-rare4.0-cil                                     all          Mono I18N.Rare library (for CLI 4.0)
ii  libmono-i18n-west4.0-cil                                     all          Mono I18N.West library (for CLI 4.0)
ii  libmono-i18n4.0-all                                          all          Mono I18N libraries metapackage (for CLI 4.0)
ii  libmono-i18n4.0-cil                                          all          Mono I18N base library (for CLI 4.0)
ii  libmono-ldap4.0-cil                                          all          Mono LDAP library (for CLI 4.0)
ii  libmono-management4.0-cil                                    all          Mono Management library (for CLI 4.0)
ii  libmono-messaging-rabbitmq4.0-cil                            all          Mono Messaging RabbitMQ library (for CLI 4.0)
ii  libmono-messaging4.0-cil                                     all          Mono Messaging library (for CLI 4.0)
ii  libmono-microsoft-build-engine4.0-cil                        all          Mono Microsoft.Build.Engine library (for CLI 4.0)
ii  libmono-microsoft-build-framework4.0-cil                     all          Mono Microsoft.Build.Framework library (for CLI 4.0)
ii  libmono-microsoft-build-tasks-v4.0-4.0-cil                   all          Mono Microsoft.Build.Tasks.v4.0 library (for CLI 4.0)
ii  libmono-microsoft-build-utilities-v4.0-4.0-cil               all          Mono Microsoft.Build.Utilities.v4.0 library (for CLI 4.0)
ii  libmono-microsoft-build4.0-cil                               all          Mono Microsoft.Build library (for CLI 4.0)
ii  libmono-microsoft-csharp4.0-cil                              all          Mono Microsoft.CSharp library (for CLI 4.0)
ii  libmono-microsoft-visualc10.0-cil                            all          Mono Microsoft.VisualC library (for CLI 4.0)
ii  libmono-microsoft-web-infrastructure1.0-cil                  all          Mono Microsoft.Web.Infrastructure library (for CLI 4.0)
ii  libmono-oracle4.0-cil                                        all          Mono Oracle library (for CLI 4.0)
ii  libmono-parallel4.0-cil                                      all          Mono.Parallel library (for CLI 4.0)
ii  libmono-peapi4.0a-cil                                        all          Mono PEAPI library (for CLI 4.0)
ii  libmono-posix4.0-cil                                         all          Mono.Posix library (for CLI 4.0)
ii  libmono-rabbitmq4.0-cil                                      all          Mono RabbitMQ.Client library (for CLI 4.0)
ii  libmono-relaxng4.0-cil                                       all          Mono Relaxng library (for CLI 4.0)
ii  libmono-security4.0-cil                                      all          Mono Security library (for CLI 4.0)
ii  libmono-sharpzip4.84-cil                                     all          Mono SharpZipLib library (for CLI 4.0)
ii  libmono-simd4.0-cil                                          all          Mono SIMD (for CLI 4.0)
ii  libmono-smdiagnostics0.0-cil                                 all          Mono SMDiagnostics Library (for CLI 4.0)
ii  libmono-sqlite4.0-cil                                        all          Mono Sqlite library (for CLI 4.0)
ii  libmono-system-componentmodel-composition4.0-cil             all          Mono System.ComponentModel.Composition library (for CLI 4.0)
ii  libmono-system-componentmodel-dataannotations4.0-cil           all          Mono System.ComponentModel.DataAnnotations library (for CLI 4.0)
ii  libmono-system-configuration-install4.0-cil                  all          Mono System.Configuration.Install library (for CLI 4.0)
ii  libmono-system-configuration4.0-cil                          all          Mono System.Configuration library (for CLI 4.0)
ii  libmono-system-core4.0-cil                                   all          Mono System.Core library (for CLI 4.0)
ii  libmono-system-data-datasetextensions4.0-cil                 all          Mono System.Data.DataSetExtensions library (for CLI 4.0)
ii  libmono-system-data-entity4.0-cil                            all          Mono System.Data.Entity library (for CLI 4.0)
ii  libmono-system-data-linq4.0-cil                              all          Mono System.Data.Linq Library (for CLI 4.0)
ii  libmono-system-data-services-client4.0-cil                   all          Mono System.Data.Services.Client library (for CLI 4.0)
ii  libmono-system-data-services4.0-cil                          all          Mono System.Data.Services library (for CLI 4.0)
ii  libmono-system-data4.0-cil                                   all          Mono System.Data library (for CLI 4.0)
ii  libmono-system-deployment4.0-cil                             all          Mono System.Deployment library (for CLI 4.0)
ii  libmono-system-design4.0-cil                                 all          Mono System.Design Library (for CLI 4.0)
ii  libmono-system-drawing-design4.0-cil                         all          Mono System.Drawing.Design (for CLI 4.0)
ii  libmono-system-drawing4.0-cil                                all          Mono System.Drawing library (for CLI 4.0)
ii  libmono-system-dynamic4.0-cil                                all          Mono System.Dynamic library (for CLI 4.0)
ii  libmono-system-enterpriseservices4.0-cil                     all          Mono System.EnterpriseServices library (for CLI 4.0)
ii  libmono-system-identitymodel-selectors4.0-cil                all          Mono System.IdentityModel.Selectors Library (for CLI 4.0)
ii  libmono-system-identitymodel4.0-cil                          all          Mono System.IdentityModel Library (for CLI 4.0)
ii  libmono-system-io-compression-filesystem4.0-cil              all          Mono System.IO.Compresion.FileSystem library (for CLI 4.0)
ii  libmono-system-io-compression4.0-cil                         all          Mono System.IO.Compression library (for CLI 4.0)
ii  libmono-system-json-microsoft4.0-cil                         all          Mono System.Json.Microsoft library (for CLI 4.0)
ii  libmono-system-json4.0-cil                                   all          Mono System.Json library (for CLI 4.0)
ii  libmono-system-ldap-protocols4.0-cil                         all          Mono System.DirectoryServices.Protocols library (for CLI 4.0)
ii  libmono-system-ldap4.0-cil                                   all          Mono System.DirectoryServices library (for CLI 4.0)
ii  libmono-system-management4.0-cil                             all          Mono System.Management library (for CLI 4.0)
ii  libmono-system-messaging4.0-cil                              all          Mono System.Messaging library (for CLI 4.0)
ii  libmono-system-net-http-formatting4.0-cil                    all          Mono System.Net.Http.Formatting library (for CLI 4.0)
ii  libmono-system-net-http-webrequest4.0-cil                    all          Mono System.Net.Http.WebRequest library (for CLI 4.0)
ii  libmono-system-net-http4.0-cil                               all          Mono System.Net.Http library (for CLI 4.0)
ii  libmono-system-net4.0-cil                                    all          Mono System.Net library (for CLI 4.0)
ii  libmono-system-numerics-vectors4.0-cil                       all          Mono System.Numerics.Vectors library (for CLI 4.0)
ii  libmono-system-numerics4.0-cil                               all          Mono System.Numerics library (for CLI 4.0)
ii  libmono-system-reactive-core2.2-cil                          all          Mono System.Reactive.Core Library (for CLI 4.5)
ii  libmono-system-reactive-debugger2.2-cil                      all          Mono System.Reactive.Debugger Library (for CLI 4.5)
ii  libmono-system-reactive-experimental2.2-cil                  all          Mono System.Reactive.Experimental Library (for CLI 4.5)
ii  libmono-system-reactive-interfaces2.2-cil                    all          Mono System.Reactive.Interfaces Library (for CLI 4.5)
ii  libmono-system-reactive-linq2.2-cil                          all          Mono System.Reactive.Linq Library (for CLI 4.5)
ii  libmono-system-reactive-observable-aliases0.0-cil            all          Mono System.Reactive.Linq Library (for CLI 4.5)
ii  libmono-system-reactive-platformservices2.2-cil              all          Mono System.Reactive.PlatformServices Library (for CLI 4.5)
ii  libmono-system-reactive-providers2.2-cil                     all          Mono System.Reactive.Providers Library (for CLI 4.5)
ii  libmono-system-reactive-runtime-remoting2.2-cil              all          Mono System.Reactive.Runtime.Remoting Library (for CLI 4.5)
ii  libmono-system-reactive-windows-forms2.2-cil                 all          Mono System.Reactive.Windows.Forms Library (for CLI 4.5)
ii  libmono-system-reactive-windows-threading2.2-cil             all          Mono System.Reactive.Windows.Threading Library (for CLI 4.5)
ii  libmono-system-reflection-context4.0-cil                     all          Mono System.Reflection.Context library (for CLI 4.0)
ii  libmono-system-runtime-caching4.0-cil                        all          Mono System.Runtime.Caching Library (for CLI 4.0)
ii  libmono-system-runtime-durableinstancing4.0-cil              all          Mono System.Runtime.DurableInstancing Library (for CLI 4.0)
ii  libmono-system-runtime-serialization-formatters-soap4.0-cil           all          Mono System.Runtime.Serialization.Formatters.Soap Library (for CLI 4.0)
ii  libmono-system-runtime-serialization4.0-cil                  all          Mono System.Runtime.Serialization Library (for CLI 4.0)
ii  libmono-system-runtime4.0-cil                                all          Mono System.Runtime library (for CLI 4.0)
ii  libmono-system-security4.0-cil                               all          Mono System.Security library (for CLI 4.0)
ii  libmono-system-servicemodel-activation4.0-cil                all          Mono System.ServiceModel.Activation Library (for CLI 4.0)
ii  libmono-system-servicemodel-discovery4.0-cil                 all          Mono System.ServiceModel.Discovery Library (for CLI 4.0)
ii  libmono-system-servicemodel-internals0.0-cil                 all          Mono System.ServiceModel.Internals Library (for CLI 4.0)
ii  libmono-system-servicemodel-routing4.0-cil                   all          Mono System.ServiceModel.Routing Library (for CLI 4.0)
ii  libmono-system-servicemodel-web4.0-cil                       all          Mono System.ServiceModel.Web Library (for CLI 4.0)
ii  libmono-system-servicemodel4.0a-cil                          all          Mono System.ServiceModel Library (for CLI 4.0)
ii  libmono-system-serviceprocess4.0-cil                         all          Mono System.ServiceProcess library (for CLI 4.0)
ii  libmono-system-threading-tasks-dataflow4.0-cil               all          Mono System.Threading.Tasks.Dataflow library (for CLI 4.0)
ii  libmono-system-transactions4.0-cil                           all          Mono System.Transactions library (for CLI 4.0)
ii  libmono-system-web-abstractions4.0-cil                       all          Mono System.Web.Abstractions library (for CLI 4.0)
ii  libmono-system-web-applicationservices4.0-cil                all          Mono System.Web.ApplicationServices library (for CLI 4.0)
ii  libmono-system-web-dynamicdata4.0-cil                        all          Mono System.Web.DynamicData library (for CLI 4.0)
ii  libmono-system-web-extensions-design4.0-cil                  all          Mono System.Web.Extensions.Design library (for CLI 4.0)
ii  libmono-system-web-extensions4.0-cil                         all          Mono System.Web.Extensions library (for CLI 4.0)
ii  libmono-system-web-http-selfhost4.0-cil                      all          Mono System.Web.Http.SelfHost library (for CLI 4.0)
ii  libmono-system-web-http-webhost4.0-cil                       all          Mono System.Web.Http.WebHost library (for CLI 4.0)
ii  libmono-system-web-http4.0-cil                               all          Mono System.Web.Http library (for CLI 4.0)
ii  libmono-system-web-mobile4.0-cil                             all          Mono System.Web.Mobile library (for CLI 4.0)
ii  libmono-system-web-mvc3.0-cil                                all          Mono ASP.NET MVC 3.0 Library (for CLI 4.0)
ii  libmono-system-web-razor2.0-cil                              all          Mono System.Web.Razor (for CLI 4.0)
ii  libmono-system-web-regularexpressions4.0-cil                 all          Mono System.Web.RegularExpressions library (for CLI 4.0)
ii  libmono-system-web-routing4.0-cil                            all          Mono System.Web.Routing (for CLI 4.0)
ii  libmono-system-web-services4.0-cil                           all          Mono System.Web.Services (for CLI 4.0)
ii  libmono-system-web-webpages-deployment2.0-cil                all          Mono System.Web.WebPages.Deployment (for CLI 4.0)
ii  libmono-system-web-webpages-razor2.0-cil                     all          Mono System.Web.WebPages.Razor (for CLI 4.0)
ii  libmono-system-web-webpages2.0-cil                           all          Mono System.Web.WebPages (for CLI 4.0)
ii  libmono-system-web4.0-cil                                    all          Mono System.Web library (for CLI 4.0)
ii  libmono-system-windows-forms-datavisualization4.0a-cil           all          Mono System.Windows.Forms.DataVisualization Library (for CLI 4.0)
ii  libmono-system-windows-forms4.0-cil                          all          Mono System.Windows.Forms Library (for CLI 4.0)
ii  libmono-system-windows4.0-cil                                all          Mono System.Windows library (for CLI 4.0)
ii  libmono-system-workflow-activities4.0-cil                    all          Mono System.Workflow.Activities library (for CLI 4.0)
ii  libmono-system-workflow-componentmodel4.0-cil                all          Mono System.Workflow.ComponentModel library (for CLI 4.0)
ii  libmono-system-workflow-runtime4.0-cil                       all          Mono System.Workflow.Runtime library (for CLI 4.0)
ii  libmono-system-xaml4.0-cil                                   all          Mono System.Xaml Library (for CLI 4.0)
ii  libmono-system-xml-linq4.0-cil                               all          Mono System.Xml.Linq library (for CLI 4.0)
ii  libmono-system-xml-serialization4.0-cil                      all          Mono System.Xml.Serialization library (for CLI 4.0)
ii  libmono-system-xml4.0-cil                                    all          Mono System.Xml library (for CLI 4.0)
ii  libmono-system4.0-cil                                        all          Mono System libraries (for CLI 4.0)
ii  libmono-tasklets4.0-cil                                      all          Mono Tasklets library (for CLI 4.0)
ii  libmono-webbrowser4.0-cil                                    all          Mono Web Browser library (for CLI 4.0)
ii  libmono-webmatrix-data4.0-cil                                all          Mono WebMatrix.Data Library (for CLI 4.0)
ii  libmono-windowsbase4.0-cil                                   all          Mono WindowsBase library (for CLI 4.0)
ii  libmono-xbuild-tasks4.0-cil                                  all          Mono Mono.XBuild.Tasks library (for CLI 4.0)
ii  libmonosgen-2.0-1                                            armhf        Mono JIT library (SGen GC)
ii  libmonosgen-2.0-dev                                          armhf        Mono JIT library - Development files (SGen GC)
ii  mono-4.0-gac                                                 all          Mono GAC tool (for CLI 4.0)
ii  mono-devel                                                   all          Mono development tools
ii  mono-gac                                                     all          Mono GAC tool
ii  mono-mcs                                                     all          Mono C# 2.0 / 3.0 / 4.0 / 5.0  compiler for CLI 2.0 / 4.0 / 4.5
ii  mono-roslyn                                                  all          Microsoft C# compiler
ii  mono-runtime                                                 armhf        Mono runtime - default version
ii  mono-runtime-common                                          armhf        Mono runtime - common files
ii  mono-runtime-sgen                                            armhf        Mono runtime - SGen
ii  mono-xbuild                                                  all          MSBuild-compatible build system for Mono

I did what you asked me to do. It is running, but changing reinstalling etc is very iffy. Could you please look into the basic problem?

ok left this for a couple of months, can anyone confirm or deny if this has been resolved, i am itching to try and get Dietpi v6.x on my devices

I it just me, or is this still an issue? Sonarr was working great for weeks or months (with many reboots and power loss), then after a power loss it just won’t come back today after 20+ reboots. I remember this happening before, but it was a couple months back and I can’t remember what I did to fix it, perhaps just uninstall/reinstall Sonarr (and/or Mono?)?

Odroid XU4

I believe it’s due to a known bug in v6.21, resolved with v6.22 ETA this weekend.

Please try to resolve:

sed -i '/After=/s/[[:blank:]]multi-user.target//' /etc/systemd/system/dietpi-postboot.service
systemctl daemon-reload
systemctl enable dietpi-postboot

That’s good to know, I’ll wait for the new release rather than fighting this thing more.

I don’t understand the code you gave, but I did run it. It doesn’t seem to have changed anything. If I uninstall Sonarr and Mono, then install Sonarr, the first subsequent boot I can access the Sonarr GUI and it seems to be working fine. Then, if I reboot again, Sonarr starts out running (checked with ‘htop’ and ‘dietpi-services status’) BUT as soon as I navigate to the GUI it won’t load, and then it has disappeared from the processes in ‘htop’ and shows as FAILED in ‘dietpi-services status’ (full readout below).

[FAILED] DietPi-Services | sonarr	failed (Result: signal) since Sat 2019-03-23 18:59:51 WITA; 17s ago
● sonarr.service - Sonarr (NzbDrone) Daemon (DietPi)
   Loaded: loaded (/etc/systemd/system/sonarr.service; disabled; vendor preset: enabled)
   Active: failed (Result: signal) since Sat 2019-03-23 18:59:51 WITA; 17s ago
  Process: 1086 ExecStart=/usr/bin/mono -O=-aot /opt/NzbDrone/NzbDrone.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr (code=killed, signal=SEGV)
 Main PID: 1086 (code=killed, signal=SEGV)

Mar 23 18:56:00 DietPi mono[1086]: [Info] episode_last_searched_time: Starting migration to 130
Mar 23 18:56:00 DietPi mono[1086]: [Info] OwinHostController: Listening on the following URLs:
Mar 23 18:56:00 DietPi mono[1086]: [Info] OwinHostController:   http://*:8989/
Mar 23 18:56:02 DietPi mono[1086]: [Info] NancyBootstrapper: Starting Web Server
Mar 23 18:56:07 DietPi mono[1086]: [Warn] MonoDebugCheck: Mono is not running with --debug switch
Mar 23 18:59:51 DietPi mono[1086]: =================================================================
Mar 23 18:59:51 DietPi mono[1086]:         Native Crash Reporting
Mar 23 18:59:51 DietPi systemd[1]: sonarr.service: Main process exited, code=killed, status=11/SEGV
Mar 23 18:59:51 DietPi systemd[1]: sonarr.service: Unit entered failed state.
Mar 23 18:59:51 DietPi systemd[1]: sonarr.service: Failed with result 'signal'.

I just tested on test VM and it works well here.

Could you please run sonarr manually on terminal, try to access and if it crashes paste debug logs from terminal:

systemctl stop sonarr
sudo -u sonarr mono --debug -O=-aot /opt/NzbDrone/NzbDrone.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr

This should log to terminal then, most likely a lot of output.
Access web UI to trigger failure (if that was the case, as far as I understood?)
Paste especially the output lines here that appeared when/after accessing the web UI

I saw the update available and did the update before seeing your reply, everything seems to be working fine now. Thank you!

Ah okay thanks for the feedback. Perhaps some mono update fixed it :slight_smile:.