Bridge wlan0->eth0

I was searching, trying, damaging my dietpi to bridge wlan0 to eth0. I tried disable dietpi network program for run network manager, but I destroyed my dietpi a few times.
Can somebody know how to create a bridge on dietpi?
Maybe this is a useful thing to add to dietpi settings

It is not difficult, however it should be also supported by dietpi network so that it doesn’t get overwritten.

By default another process doesn’t allow to make bridge with wlan0

can you be a little bit more specific, which process block the configuration?

I don’t know. I know that dietpi has a lightweight program to control interfaces and it block access to manage wlan0 with programs like Networkmanager, bridge utils.

that might be a misunderstanding. DietPi uses dietpi-config to manage interfaces. At the end the script is doing noting else than managing entries in /etc/network/interfaces configuration file. It did not block anything. It’s more the other way around. If you go to manage /etc/network/interfaces yourself, you will most probably loose possibility to manage interfaces via dietpi-config.

What device are you trying this on?

I did some poking around

Not sure if that is kinda what you are looking for

I also saw where NetworkManager might be able to be used to create a shared connection thru a bridge…all of them seemed to use the gnome desktop…then I saw the nmcli command stuff
Gui version →

nmcli versions

It still looks like it might be a kernel issue with hostapd

I didn’t know Joulinar that raspberry pi onboard wifi don’t support bridging.

WarHawk I tried bridge by NAT, but I had to restart raspberry pi every day becouse network often stopped working.

Gnome NetworkManager is good solution, but I don’t know how to do this with dietpi. I removed /etc/network/interfaces and dhpcpd5, but NetworkManager and ifconfig didn’t see wlan0 after that.

I was able to compile and get hostapd working (see this thread)
But haven’t gotten it tested any further…it is compiled on and for a Raspberry Pi0W…so YMMV…

I didn’t know @Joulinar that raspberry pi onboard wifi don’t support bridging.

where did you get this statement from?

ifconfig didn’t see wlan0 after that

Many Linux distributions have deprecated the use of ifconfig and route in favour of the software suite iproute2. Most likely it will not change anything but you should start using ip command instead of ifconfig

Joulinar from reddit

Yes, I tried also with ip link show etc, but it doesn’t help. With auto setup=1 in /boot/dietpi.txt I see wlan0 in ifconfig or ip, but I can’t manage this interface by nmcli or another networking software, when I disable autosetup ifconfig or ip doesn’t see wlan0 interface

if not configured, WiFi will be disabled and need to be activated in dietpi-config first.