Bluetooth not usable - RPi Zero 2 W

Hi all,

I did a fresh install of dietpi 7.7.3 and activated Bluetooth via dietpi-config.

I can now start (just starting, nothing more) bluetoothctl without an error message.
This changes after reboot, then I get “Waiting to connect to bluetoothd…”
This can be solved by loading btusb via modprobe and systemctl start bluetooth.
So this is the first thing which is not OK.

Starting bluetoothctl, I get “Agent registered”.
Executing “scan on” brings: “No defailt controller available”
“power on” the same.

Can you give me some advice on these two (maybe connected) issues?

Thank you!


I now tried with latest raspberry official OS (32 lite), worked out of the box.
Also tried dietpi beta 7.8.1, no success…

On DietPi v7.7.3 this is expectedly not working yet, since this new RPi models is not yet detected to have onboard WiFi, hence Bluetooth is not enabled correctly. Support will be added with v7.8, released tomorrow.

Please try to upgrade to the beta branch v7.8, then enable Bluetooth (or if enabled already, disable and re-enable it), then reboot. Logs can then best be checked via:

journalctl -u bluetooth -u hciuart

Hi Micha,

thanks for answering, I really appreciate that!

Disabling and reenabling bluetooth did the trick! Since I already had upgraded to 7.8.1 and it was not functioning I didn’t tried that.
Thank you for your help!