Blank Screen Since Enabling LightDM auto-login

Hi,
First time using DietPi. I have a little experience with Linux and Pi. I flashed, installed, updated, and rebooted DietPi successfully. Then, installed LXDE GUI, AdGuard, Mycroft, Snapcast and Shairport, & enabled “LightDM auto-login“ in the DietPi-config. Now, on boot, all I get is a blank screen. SSHing in, I switched the boot option back to “Terminal, Manual login” but still get a blank screen on boot.

Can anyone suggest a fix for this? What’s the best way to enable LXDE and have it the default interface after installation? Terminal in SSH works but I’d like a GUI interface with the Rpi display.

Using Rpi 4b with Rpi 7” display, running DietPi v7.3.

Well, I reflashed Deitpi and reibstalled everything but Mycroft. LXDE now works like a charm. :smiley:

thx for sharing. Interesting that re-flashing fixed it. Maybe there was some corruption/inconsistency on the first attamed.

I have a feeling that MyCroft was responsible. No proof other than I didn’t install it when I reflashed the microsd card. Also, MyCroft was a huge install. Perhaps it broke something?

I guess we will never find out, except you as in mood to install it again :wink: