Bitvise SSH stopped working after Win10 1803 update

I installed the Windows 10 1803 update on my laptop and desktop systems. After this, Bitvise fails to connect with SSH from both systems, and to both my Raspberry Pi’s (3B and 3B+, both running latest DietPi).

PuTTY still works, but I prefer Bitvise. I’m not sure whether this is a problem with Windows, DietPi or Bitvise itself…

(fingerprint etc. replaced with ‘x’ by me

17:48:56.315 Current date: 2018-05-08
17:48:56.315 Started a new SSH2 session.
17:48:56.317 Connecting to SSH2 server
17:48:56.319 Connection established.
17:48:56.348 Server version: SSH-2.0-OpenSSH_7.4p1 Raspbian-10+deb9u3
17:48:56.348 First key exchange started. Cryptographic provider: Windows CNG (x86) with additions
17:48:56.653 Received host key from the server. Algorithm: Ed25519, size: 256 bits, MD5 fingerprint: x, Bubble-Babble: x, SHA-256 fingerprint: x.
17:48:56.834 The SSH2 session has terminated with error. Reason: Error in component session/transport/kexHandler. Error class: Flow, code: ComponentException, message: Exception in component: Windows CNG (x86) with additions: AsymKey: CngAgree: unexpected secretData->cbStruct.

Yes, receiving the same error after the update.

I don’t know about bitvise or why it changes behaviour after Windows update, but my assumption is that it stores connecting settings, including SSH server connection keys etc. within Windows somehow, while PuTTY stores everything within its own created places (own registry entries, as far as I know). As Windows feature updates remove quite much of the old system, these SSH connection settings might be lost as well.

Thus I would try to remove all connection related settings from bitvise and re-add the SSH info to connect to the server.

If this does not work, try to switch from dropbear to openssh vise versa on the Pi. Might be some protocol incompatibilities with whatever bitvise uses from new Windows.

But this is definitely not my profession. Would need some testing, if I find the time.

Well, I ended up uninstalling Bitvise completely, deleted all .tlp profiles, downloaded the installer again and re-installed. Now it seems to work.

Bitvise SSH - Error in component session/transport/kexHandler
Unable to SSH into brand new droplet
Digitalocean droplet SSH PuttY access denied
Bitvise SSH error after windows 10 1803 update…
Key exchange error with Bitvise SSH Client

Ref : Bitvise connecting error LocalSshDisconn | Guest Blog Posting

“…We tried to connecting to my digital ocean droplets SSH, via Bitvise SSH client.
It is working well with my old servers but not for my freshly created new droplet server…”

Solution : This issue is known as the bitvise client need to be upgraded to at least 7.41 or latest…