BAZARR cannot parse JSON returned by SignalR feed


last days i get the below error and bazarr is always synch episodes from sonarr

BAZARR cannot parse JSON returned by SignalR feed. This is caused by a permissions issue when Sonarr try to access its /config/.config directory. You should fix permissions on that directory and restart Sonarr. Also, if you’re a Docker image user, you should make sure you properly defined PUID/PGID environment variables. Otherwise, please contact Sonarr support.

I see you opened as well an issue at Bazarr GitHub

pls reboot your system and share the 2 log files.

cat /var/log/bazarr/bazarr.log
cat /var/log/sonarr/sonarr.txt

only bazarr has logs , sonarr log file is empy

I uploaded the file at wetransfer because is 100MB the bazarr logs

it doesn’t make sense to have a look into 100MB log file. Pls can you restart your system and check the logs again. Hopefully this will clear/shrink logs a little bit

Before I retrieve the logs I made a reboot

did you tried to contact sonarr support on the issue? probably they are able to help with identifying which files are in question as I’m not sure which /config/.config file we are looking for. On DietPi we have following folders


can you maybe share following

ls -la /mnt/dietpi_userdata/sonarr

Thank you

I found the in dietpi_userdata/sonarr every time that I reboot the rpi change the permissions to 777 and I changed it manually to 660. When I changed the permissions the issue solved with bazarr until next reboot

did you stored your user data on an external USB device? because permission did not change by their own.

Nop sonarr userdata located to the below path


the path will be same, even if you have it located on an external disk :wink:

usually there is nothing in our scripts wich changes permissions during reboot. Usually they should be persistent. Your are not using any r/w protection or overlay?