Banana Pi M1

Hi Fourdee,

Just installed DietPi on this device and pleased to report it works. I did all the updates and it is running v127. I hooked up a 120 GB HD to the SATA port and this works fine also.

Not sure if this will be my third Diet Pi device (XU4 and Pi2 the others) as it has been very stable running Bananian and I have a lot running on it - I have reinstalled all my stuff on the XU4 so it is my backup machine in case the XU4 fails.

I know you don’t have one of these so if you want me to run any tests let me know.


Hi John,

Excellent, thanks for letting me know.

Did you use the DietPi BRi Pro image (A20 ARM) for this?

Hi Fourdee,

I used DietPi_v127_BananaPiPro-armv7-(Jessie). I have since installed a few things, lighttpd, MySQL, phpMyAdmin all working well as it seems very fast compared to Bananian but Bananian had a lot installed. Might just keep it running DietPi for a while :slight_smile:


Hi John,

You’ll need to get the correct .fex (converted to .bin) file, to prevent possible overvolting and damage to your M1. The .fex contains various power settings, memory clocks etc specific for your device, applied during boot.

Download this file (M1+, but should be fine for M1 also): (ADMIN EDIT: Removed outdated link)

And copy it to /boot/script.bin. After a reboot, it will be loaded.

HI Fourdee,

Tried this but the system wouldn’t boot - changed back and all OK. I’ve powered it down for the time being.


Hi John,

Apologies. I had a quick look through ARMbian source code to try and see which fex is applied. Unable to find it so far.

I think this might do it, if we assume the M1 was the 1st BPi produced: (ADMIN EDIT: Removed outdated link)
Might be best to verify with ARMbian, just to be sure.

Hi Fourdee,

Boots and just updated to 128 - looking good so far - thanks.


Hi John,

Excellent, the M1 must of been the 1st BananaPi board. Maybe it didn’t have M1 in its name back then, hence bananapi.bin looks like the correct fex.

Hi Fourdee,

When I got it it (Christmas 2014) was known as the Banana Pi as it was the only model in the range then, a nice device especially with an SSD on the SATA port. I’t running well on DietPi - uptime of almost two days now. On Bananian I had it running reliably for two months without a reboot. One of my collection of 5 SBCs having sold off two Pi model B Pis recently. Three run DietPi, one OSMC, one LibreElec.


Thanks for making a good and efficient OS.

Would be testing it out soon on my Banana Pi M1 version.

Please advise the steps to install the Kodi software on top of the DietPi.

ED. :slight_smile:

Not possible at the moment, GPU support is not implemented on our image for the M1.

The following images are Kodi ready, with full GPU support:

  • RPi (all)
  • Odroid (all)

Is it too difficult?

I came across this info. Wetek Play already have support of this Mali-400MP2 GPU in WeTek OpenELEC / Kodi Installer.


In KODI, it is stated as follows:

WeTek Play (also sold as an WeTek OpenELEC edition) is an ARM-based media player device that can currently run either Kodi on Android or on Linux, both using official first-party firmware images provided by WeTek and OpenELEC development teams which comes with Kodi pre-installed. WeTek Play is also one of the first Kodi based set-top box devices that have support for integrated ATSC and DVB TV-tuners, which are currently fully functional via plug-and-play under Android and Linux in combination with Tvheadend PVR backend or VDR PVR backend and its matching PVR client addon for Kodi.


Hope it can be done. :slight_smile:

Thank you.


Sorry for resurrecting this dead old topic, but that’s exactly what I wish to discuss. :slight_smile:

I have an old Banana Pi M1 board and wish to make a use of it (a backup server using rsync via ssh). I feel that the last resort is to use DietPi, otherwise everything else I tried is simply sluggish.

I cannot find a suitable download to run DietPi on this board, and it seems that the one mentioned by the thread creator is somehow dangerous (?), and for sure is outdated.
Any hints where do I find an image I could try?




I don’t think there is an official image for your board available. However you could try the following if you have time to play around. No grantee that it will work

  1. Setup the available Armbian image for Bananapi M1
  2. if this is running, try to setup DietPi using this guide

Awesome, thanks!

I assume I am supposed to pick “Buster”, not “Bionic”. I’ll let you know how it went.

Buster image should be fine

I used Buster image (Minimal, it was tricky to find).
Two broken SD cards later, I run Armbian and DietPi, I think this is all working. :slight_smile:
Except I couldn’t finish installation because I assumed this is going to fit on 2GB card :thinking:

[FAILED] DietPi-Software | Free space check: path=/ | available=309 MiB | required=500 MiB
[FAILED] DietPi-Software | Install aborted due to insufficient free space

So, in case anyone is wondering just like me, yes, you can install DietPi this way!
Thank you for your help!

So just to recap, you downloaded the Armbian Buster image and set it up. Once running you used DietPi magic script to install DietPi on top. Right?

That is correct. I didn’t use the default Buster image, but the “Minimal” you can find on the very bottom of that page you suggested.
Then I run the DietPi script. It did show one error in the process - it had something to do with mounting or unmounting /tmp, but like I said, I used too small SD card and that might be the reason for that error. I’ll make sure to write it down next time if it happens again.
I already ordered 16GB A1 SanDisk and will report back when I try that again in next few days.