backup/restore strategy...

Hello guys,

I was wondering what the best backup/restore strategy is for dietpi. Right now what i do is:

automated backup: (script)
copy config files & root-folder to usb/dietpi_userdata & nas

flash sd-card with dietpi
change root-passwd/timezone
run restore script (sets lib-path,apt-get update && upgrade, installs apps and after that copies config-files, sets crontab)

Is there a better, faster, other way?

Have you tried DietPi-Backup?

Backup system:


You can create a full system backup (default /mnt/dietpi-backup)

Restore (automated, no GUI):

dietpi-backup -1

Hello Fourdee,

I know about dietpi-backup. Perhaps i will use it. I need to read-up on it. (i didn’t know that it could automatically restore!)


Hello Fourdee,

My experience with dietpi-backup:

-Often freezes (on a random file).
-If i am remotely connected (ssh), connection is terminated. If try to reconnect i can logon (login/password) but the ssh-process doesn’t continue. (i get no prompt)

I am on a freshley installed OdroicC2 (diet-pi 1.59). Everything is updated/upgraded. Processes in the background are: “motion” , “apache2” , “gnuplot” and samba-server. I have tried a dietpi-backup without these processes in the background before but mostly with the same result (big freeze).

(i haven’t niced any processes/gov is still ondemand)

I have had these experiences with dietpi-backup also on my former SBC.(Orange Pi plus)

I you want i can send a log (if you tell me where this log can be found).


ps: i choose for source: “/” and for destination the sd-card (30 Gb free space, new sd-card). I excluded *.jpg *.jpeg and *.png
ps2: In all fairness… I have had problems with my OdroidC2 (i blame the power-source which i replaced). After that my SBC runs smooth and keeps running (also after reboots).

i had a notion: i tried to ssh again to the SBC. ( i am not at home) I got in but no prompt. I did ctrl-c and got a prompt. That was at 2018/01/22 14:30…

Found the log…

log ends like this:

2018/01/22 10:02:38 [20938] >f+++++++++ etc/fonts/conf.d/README
2018/01/22 10:02:38 [20938] cd+++++++++ etc/groff/
2018/01/22 10:02:38 [20938] >f+++++++++ etc/groff/man.local
2018/01/22 10:02:38 [20938] >f+++++++++ etc/groff/mdoc.local
2018/01/22 10:02:38 [20938] >f+++++++++ etc/dropbear/log/run
2018/01/22 10:02:38 [20938] cd+++++++++ etc/emacs/

Nothing more after that…

ps: i just find out that my new sd-card has flaws… (damn).

It explains a lot

ps: nope, sd isn’t defective. I am at a loss here

Last post about this:

I made a stupid mistake in a script which led to all this corruption problems. Everything is fine (sd cards, SBC, power supply, card-readers, cables, dietpi)

My mistake: I made a which starts with:

“export LD_LIBRARY_PATH=/lib/arm-linux-gnueabihf:/usr/lib:/usr/local/lib:/opt/vc/lib”

Then does a" apt-get update / upgrade".

After that it starts installing stuff (rsync/motion, libtool, etc) and that’s my mistake! It should have FIRST rebooted!!! and then i should have started installing stuff…

Learned another lesson!