Audio on Pine SOQuartz / Quartz64

Hello, I’ve just recently begun setting up a Pine64 SOQuartz compute module with the Model A baseboard. I tried DietPi and so far the process has been going pretty well after getting proper SD cards and heatsinks. One problem I have is that I cannot seem to get any kind of audio from it. There is no HDMI audio and apparently the only audio output is analog audio but this is not available on the Model A baseboard. I have no idea how to fix that and searching doesn’t give me any useful information.I would use a set of Bose USB speakers that I use with my Ubuntu laptop, but it seems that the kernel doesn’t have the snd-usb-audio module. So I have basically no options for sound with the kernel as built. I’d try rebuilding the kernel myself just for the USB audio module if I could find the kernel source tree for it.

Any help or suggestions for getting sound on my machine?

Did you activate audio support and install ALSA via dietpi-config > audio options?
Because there is an option usb-dac : USB Audio DAC (any)

1 Like

Is ALSA audio enabled?
might also ensure the user playing audio is added to the audio group
sudo usermod -a -G audio youruser-here

does aplay see the USB device?
aplay -l

# dietpi-config
then enable alsa in the audio options, reboot then see what it says

Solved already via PINE64 forum. ALSA was not installed/enabled: DietPi OS for Quartz64

1 Like