ASUS Tinker Board not booting with DietPi

I recently bought a new ASUS Tinker Board S to upgrade from my Raspberry Pi 3 B (where I currently have a DietPi setup.).

I did all the usual prep:

  • Formatted my SD card with SD Card Formatter’s “overwrite format” option
  • Downloaded the latest Tinker Board image and flashed with Etcher
  • Plugged it into my Tinker Board and booted it with peripherals (USB keyboard and HDMI to TV) with a 5.1V, 2.5A power supply

However it didn’t boot up as expected - no HDMI signal or flashing lights. The only indication that it was actually powered was a solid red light. I left it for about 10 minutes before starting from scratch with the same result.

Some troubleshooting I’ve done:

  • Tested with other SD cards
  • Formatted and flashed the SD in both a Mac and Windows environment
  • Flashed the SD card with the official TinkerOS image. This booted instantly with no issues.

I then remembered when setting up my Raspberry Pi last year, I was able to access the file system on the SD card in order to change a few settings before booting it up. I’m not able to do this after flashing for the Tinker Board.

To verify, I flashed the SD card with the latest RPi image and confirmed I was able to access the file system, ie.

After flashing RPi image:

After flashing Tinker image:

Any idea what the issue could be? Really hope I can get this sorted as I love the DietPi system and don’t want to have to resort to an alternative.

I ran into this same issue, but I think it has to do with the boot priority and / or lack of “U-Boot” (I’m still new to this whole SBC thing). I moved the jumper into the MASKROM position and was able to boot and install DietPi.

Now I just need to figure out why all the browsers keep crashing.

Follow-up on my experience: I ended up flashing directly to the eMMC by plugging it into my computer (with the jumper out of MASKROM and into the normal position [next to HDMI port]) using the DietPi image and balenaEtcher.

This did it, thank you!! I didn’t even consider that it might be trying to boot from the eMMC. I changed the position of the jumper and it booted up straight away with no issues. I haven’t finished with my install yet (will be doing so this weekend), but if I run in to any performance issues then I might try and flash the eMMC and see how that goes. Thanks again!

Not a problem. I was pulling my hair out over it. I think it’s something wrong with the image, because TinkerOS booted just fine from the SD card, but no one seemed to be saying anything about it.

You’ll probably run into the issue where the browsers crash. There’s a workaround to make Chromium, at least, work here:

Hey guys. Sorry for the late participation. Okay so first thing is that you need to set the jumper to define where the ATB should boot from. So the image then can boot from both, eMMC (if you manage to flash it) and SDcard, right?

It will only boot DietPi from an SD card if you have it in MASKROM mode for some reason. If you flash another image to an SD card, e.g., TinkerOS, it boots fine without the jumper in MASKROM mode.

From the Tinkerboarding Wiki:

There are 2 check points during the whole boot process.

  • One is SoC search for U-Boot and the other is U-Boot search for Kernel.
  • Once Tinker boot to Kernel, the Kernel will load the rootfs which is at the same storage with Kernel if you did not specify the boot parameter root=/dev/xxx at the Kernel cmdline. In other words, you can assign the rootfs path by Kernel cmdline at extlinux.conf.

Check Point

  1. SoC will search eMMC U-Boot first then SD card, it means eMMC > SD card
  2. U-Boot will search eMMC Kernel first then SD card, it means eMMC > SD card

As the above 2 items, the boot priority is always eMMC first. So we reserve one way to disable eMMC and force Tinker Board S to boot from SD card. You just insert the jumper as the following way(MASKROM mode), then the H/W will disable the eMMC.

Sorry for resurrecting this old thread, but I have the same issues with a Tinker Board 2S and it doesn’t want to boot with dietpi.

After testing with different jumper configurations and checking power and video cables, before going further I just want to be sure that dietpi at the moment is compatible with the 2S version of the asus tinkerboard.

I don’t know if the image should work with the 2S, but since the Tinker OS is based on Debian, you could give it a try and install Tinker OS and after that run the dietpi-install script: