Armv6 bookworm software test matrix question

Quick question, Why am I getting an ‘illegal instruction’ error when running certain software like PHP and Chromium on ARMv6, even though they are marked as green on GitHub?

I’m using RPi zero, sure it’s low power (both kind of power) sbc, i do understand that few articles said chromium is no fun but green is green, except it’s wrongly placed. Also php should work, at least using docker is.

What do you mean, it is marked as green?
And can you post the full error message?

From Debian Bookworm testing · MichaIng/DietPi Wiki · GitHub

I believe green means supported/runs, read means not supported or others with notes.

ERROR logs simply spout “illegal instruction” when running php -v

Php installed using dietpi-software

the matrix is no garantee that thinks are working. It was at the point of testing. But Debian Bookworm is still a testing version, threfore things might goint to change. Even bugs could arrive at Bookworm still.

Well duh, the reason I’m upgrading to bookworm test is that list, too bad it’s not really actual result

I need headless chromium and tried it on bullseye, I got “illegal instruction” too even tough it said that new package has been built and proven to run very slow on RPi zero.

Looking out for reason, seems like more and more armv6 support was dropped, and those armhf package that served is for armv7.

Is there any possibility that package served is mixed? I mean, it probably have armv6 package but when apt request it, server gives armv7 instead since both are armhf

Chromium is already broken (for ARMv6) on Bullseye since a year or so. The RPi devs fixed it, but while it started, it was so unbelievable slow, unusable on my max overclocked device with all performance tweaks applied. Hence we disabled Chromium in general on ARMv6. Even Firefox does not work… Bug #1956152 “[Bullseye] Firefox fails on ARMv6” : Bugs : Raspbian
I’d say that hence an RPi Zero isn’t suitable anymore for this job, sadly. RPi Zero W 2 of course would work fine.

Broken PHP reported here: Bug #2012833 “[Bookworm] PHP 8.2 fails with “Illegal instruction...” : Bugs : Raspbian

I updated the test matrix accordingly and added a timestamp to the changed entries, which we should consequently do now.

EDIT: Actually, since the chromium-browser package shipped on Bookworm should be the same as on Bullseye, and was at least working again, did you really try to install that one or the chromium package instead (which is expected to fail)?

I’d say that hence an RPi Zero isn’t suitable anymore for this job, sadly.

yeah, i just want to try it out using puppeteer, some minutes delay not a problem i think, also i still able to install it manually using apt so not a problem even if its disabled on dietpi-software.

updated the test matrix


chromium-browser or chromium

im told that on rpi system, chromium-browser is recommended. but anyway, i tried both, chromium-browser first then chromium, both end up illegal istruction.

Okay then it seems that what worked for a while broke again. This is also the reason we kept it disabled as I expected this not to last for long.

But just to be sure, did you run chromium-browser successfully on Bullseye recently? In theory it could be a shared library now, instead of the browser itself, causing the illegal instruction.

yes i did test, and got illegal instruction on bullseye too (thats why im trying bookworm after looking at software test, i tought its magically fixed on bookworm)

Okay, then keeping the install option disabled on ARMv6 was the right choice. Just for reference, here the GitHub issue about the initial ARMv6 chromium-browser breakage and the fix: [Bullseye] Chromium fails to start on ARMv6 · Issue #21 · RPi-Distro/chromium-browser · GitHub
But it really sounds like this was a one time fix and there is not much motivation to re-apply it on every new (upstream) Chromium release.

well, even tough i kind of given up with chromium, im still hoping for simple automation with whatever delay. there are no information on which version chromium-browser works, what patch applied, the only possibility to work with chromium-browser probably using buster images.

also with same topic, i believe portainer is no longer supporting armv6.

Oh you are right:

latest: Pulling from portainer/portainer-ce
docker: no matching manifest for linux/arm/v6 in the manifest list entries.

So we need to disable the option on ARMv6. I’m also sad that those old RPi’s loose their options, but I can understand it since it becomes an increasing burden to keep up support and build workflows for them, with a decreasing number of users benefit from it. The armv6hf architecture always required a special set of build tools and/or libraries as most distributions (including Debian) do not natively support it. Developers and maintainers see those extra efforts better invested in tasks which more user benefit from.