AriaNG can't download any files!

I’m using latest version of dietpi through vmware workstation and the same setup with my raspberry pi 3b.

I installed ariang docker and no issues downloading files with ariang when it runs with vmware workstation!
I try the same configuration on my raspberry pi 3b and no issues installing ariang and accessing web interface but I can’t download any files? It says Aria2 status connected and files that I try to download appears in the download list and eventually times out without downloading!

As an exemple, I try to download Winzip demo ( After a minute it says under Task Status : Error Occured (2) and we see : Operation Time Out but the same setup work when AriaNG is installed in the virtual machine!

I run only one aria2ng instance at a time. From SSH, I can access the network drive with folders in it (I see them in Webmin too).

mkdir -p /mnt/samba/aria2ng/downloads
mkdir -p /mnt/samba/aria2ng/config
mount -t cifs -o username=“Htpc”,password="" // /mnt/samba/aria2ng/downloads

docker pull hurlenko/aria2-ariang

docker run -d
–name ariang
-p 8080:8080
-v /mnt/samba/aria2ng/downloads:/aria2/data
-v /mnt/samba/aria2ng/config:/aria2/conf
-e PUID=0
-e PGID=0
-e RPC_SECRET=dietpi

I don’t know if it’s write access issue to save the files on Samba share (but why that issue is not present in virtual machine with the same configuration?). I try to find out if it’s ariang docker bug or issue with dietpi or docker or something else. I tried with PUID=1000 and PGID=1000 and it failed too!

I installed many other dockers and they all works like Droppy.

Aria2log.txt (1.19 KB)


I did exactly the same like you on my RPi3B+ and downloading stuff is working without issues. There shouldn’t be any issue with SAMBA as docker is executed as root user. As well you get an Operation Time Out. This seems more a network issue and you are not able to get the download started. But let’s check. Can you have a look to AriaNg > Aria2 Settings > Basic Settings > Log File. Just create a log file /aria2/data/log.file. Now, try to download Once failed, go to your SAMBA share, open the log.file and search for something starting winzip25.

On my installation I see following

2020-11-22 21:03:37.701813 [DEBUG] [] 1 RequestGroup(s) added.
2020-11-22 21:03:37.702070 [INFO] [] CUID#16 - HttpServer: all response transmitted.
2020-11-22 21:03:37.702128 [INFO] [] CUID#16 - Persist connection.
2020-11-22 21:03:37.702223 [DEBUG] [] CUID#17 - socket: read:0, write:0, hup:0, err:0
2020-11-22 21:03:37.702363 [DEBUG] [] Selected from fastCands
2020-11-22 21:03:37.702458 [DEBUG] [] FeedbackURISelector selected
2020-11-22 21:03:37.702590 [DEBUG] [] CUID#17 - socket: read:0, write:0, hup:0, err:0
2020-11-22 21:03:37.702673 [INFO] [] CUID#17 - DNS cache hit: ->
2020-11-22 21:03:37.702738 [INFO] [] CUID#17 - Connecting to
2020-11-22 21:03:37.703780 [DEBUG] [] CUID#17 - socket: read:0, write:0, hup:0, err:0
2020-11-22 21:03:37.727849 [DEBUG] [] CUID#17 - socket: read:0, write:1, hup:0, err:0
2020-11-22 21:03:37.728108 [DEBUG] [] CUID#17 - socket: read:0, write:1, hup:0, err:0
2020-11-22 21:03:37.728163 [DEBUG] [] Creating TLS session
2020-11-22 21:03:37.728246 [DEBUG] [] GnuTLS: <5> REC[0x1300d00]: Allocating epoch #0
2020-11-22 21:03:37.728550 [DEBUG] [] GnuTLS: <2> added 4 protocols, 29 ciphersuites, 18 sig algos and 10 groups into priority list
2020-11-22 21:03:37.728624 [DEBUG] [] TLS Handshaking
2020-11-22 21:03:37.728691 [DEBUG] [] GnuTLS: <5> REC[0x1300d00]: Allocating epoch #1
2020-11-22 21:03:37.728767 [DEBUG] [] GnuTLS: <4> HSK[0x1300d00]: Adv. version: 3.3

Thanks for the quick reply! Here’s a copy and paste of partial log file that might help find the issue!

2020-11-22 22:01:41.760328 [INFO] [] CUID#10 - HttpServer: all response transmitted.
2020-11-22 22:01:41.760385 [INFO] [] CUID#10 - Persist connection.
2020-11-22 22:01:41.760582 [INFO] [] CUID#24 - HttpServer: all response transmitted.
2020-11-22 22:01:41.760638 [INFO] [] CUID#24 - Persist connection.
2020-11-22 22:01:42.762119 [DEBUG] [] CUID#31 - socket: read:0, write:0, hup:0, err:0
2020-11-22 22:01:42.762249 [DEBUG] [] ServerStat: set status ERROR for (https)
2020-11-22 22:01:42.762310 [DEBUG] [] CUID#31 - All IP addresses were marked bad. Removing Entry.
2020-11-22 22:01:42.762501 [INFO] [] CUID#31 - Restarting the download. URI=
Exception: [] errorCode=2 URI=
→ [] errorCode=2 Timeout.

If it helps, I have docker installed through dietpi installer. I reinstalled it with command line and reboot (router and rpi). I also have Pi-Hole 5 latest version installed (I upgraded since it was final version but never uninstall and reinstall it). I can save files from one windows 10 pc to the other windows 10 pc (samba share) from the internet and from one pc to the other one. 100% of apps installed come from dietpi installer or from docker. Also Rpi is Ethernet, wifi is disabled. Rpi connectivity test confirms that internet works and also all my devices works to surf on the internet.



not sure why but your container has some issues. Maybe some issues with interface setup.

2020-11-22 22:01:42.762249 [DEBUG] [] ServerStat: set status ERROR for (https)
2020-11-22 22:01:42.762310 [DEBUG] [] CUID#31 - All IP addresses were marked bad. Removing Entry.

you could try to ping something from inside the container

docker exec -it ariang ping

I’ll try it and in the mean time, some more info about my setup!

*** Appz installed with docker ***

  • droppy with ports 8989:8989
  • daapd with port 3689
  • heimdall with ports 5331:80 and 443:443
  • portainer with ports 9000:9000
  • ariang with port 8080:8080

*** Appz through dietpi installer ***

  • Pi-hole v5.1.2
  • Webmin
  • Samba

Do you believe Pi-Hole, the network interfaces in Webmin and or Portainer could cause or indicate a problem?
If there is anything I can try before formatting and reinstalling dietpi from scratch it would be nice!

as said, you could try to ping something from inside the container

docker exec -it ariang ping

If I ping IP ( it works!

root@RaspberryPi:~# docker exec -it ariang ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=114 time=27.156 ms
64 bytes from seq=1 ttl=114 time=26.733 ms
64 bytes from seq=2 ttl=114 time=36.558 ms
64 bytes from seq=3 ttl=114 time=26.074 ms
64 bytes from seq=4 ttl=114 time=25.608 ms
— ping statistics —
13 packets transmitted, 13 packets received, 0% packet loss
round-trip min/avg/max = 17.109/25.057/36.558 ms

If I ping domain it fails! What can I do?

root@RaspberryPi:~# docker exec -it ariang ping
ping: bad address ‘

seems to be an issue with DNS. Let’s check configured DNS server

docker exec -it ariang cat /etc/resolv.conf

and try to resolve a host name

docker exec -it ariang nslookup


*** At the docker level ***

root@RaspberryPi:~# docker exec -it ariang cat /etc/resolv.conf

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)



root@RaspberryPi:~# docker exec -it ariang nslookup
;; connection timed out; no servers could be reached

*** By opening SSH session in RPI ***
root@RaspberryPi:~# cat /etc/resolv.conf

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)


root@RaspberryPi:~# nslookup

Non-authoritative answer:
Address: 2607:f8b0:4020:807::200e

It’s strange that it works everywhere else (including my 2 Windows 10 PC and virtual machines)!
My router is : TP-Link TD-W8980 (N600 Wireless Dual Band Gigabit ADSL2+ Modem Router)

I have 3 pages of settings that I modified since Pi-Hole was installed last year. I may have put incorrect settings after reading the documention on Pi-Hole web site.

As Pi-Hole settings, I choose Google DNS but I believe ads were not blocked so I also choose options in my router : Set DNS server manually and put Google DNS here. Should I remove that (Picture 1)?

Also, according to my understanding of Pi-Hole, I understood that I choose change DNS server to the IP address of my Raspberry Pi ( Should I remove that (Picture 2)?

I also put DNS server of my Pi-Hole (Picture 3). Should I remove that?

I have multiple computers and devices. I have no issues surfing, downloading, pinging including including virtual machines but I might have wrong settings there and could be losing perfomance… I suspect either the settings on my router that you see that are incorrect and/or something with Pi-Hole!


slowly I get what happen. Is PiHole running on same system running as Docker? If yes, can you check if Pihole is set to Listen on all interfaces?

Yes, I have Pi-Hole running on the same system as Docker! With DietPi software installer, I choose both Pi-Hole and Docker to be installed.

At the time, it was Pi-Hole 4 through DietPi installer. Then version 5 (pihole -up to update from SSH). I had no issues to my knowledge either with v4 or v5 and at that time I wasn’t playing with docker yet… Maybe settings were fine and my mistake was pihole -up ? I could have uninstall and reinstall from your software menu but not sure at that time if version 5 was available from menu…

I used default settings in Pi-Hole since I’m using it. It says : Listen only on interface eth0. My dietpi is only using ethernet (wifi is disabled). I saw the option but with the warning I prefered at that time leaving it like that and especially that everything was working (all my devices and apps except this glitch that I have this docker now). And everything is working so I believe that Pi-Hole was setup properly with default settings from your installer.

They only thing that I don’t understand is why I need to put Google DNS manually in my router if I choose the same Google DNS in Pi-Hole? Maybe because my settings are incorrect in Pi-Hole that I had to do that in the router? And mabe my settings in the router are not needed?

As long as it’s safe, I don’t mind changing it. Which option would you recommand in Pi-Hole? And what more would it do compare to the actual setting?

Is there any settings in my router that I should removed (DNS of Google) and maybe some other settings in the screenshots?
Pi-Hole Settings.png

You don’t need to change anything on your router. You can have it pointing to PiHole. That’s not the problem. Your challenge is that PiHole is not reacting on request coming from Docker running on the same DietPi system. You would need to set PiHole to Listen on all interface. This is needed as Docker has it’s own interface docker0 and is not using eth0.

Thank you for the clarification and for your assistance; it’s working like a charm and I understand what you told me and it make sense that router points to my RPI IP ( but there one thing that I don’t understand.

Why do I need to hardcode Google DNS in my router because it’s already choosen in Pi-Hole?

I guess your router makes a difference between internal LAN settings and external WAN setting. Probably DNS server on WAN would need to be something reachable on the internet. And PiHole is reachable inside your LAN only. But I need to say, I’m not familiar with your router. Maybe there are guides on the web how to configure a TP-Link together with PiHole.

Thank you again for your help. DietPi is so amazing! I never tought I would do that much on a 35$ RPI computer with only 1 Gb of RAM! It Windows 10 had an option to be light with that flexibility, it would be amazing but I still perfer DietPi, way more control and it’s so nice to have many programs that can be installed without any difficulty!