Archer TP-link AC600 T2U

Creating a bug report/issue

Required Information

  • DietPi version | core 8, sub 16, branch rc2, master michaing, no love patch
  • Distro version | bullseye
  • Kernel version | linux
  • Architecture | amd64
  • SBC model | Native PC (X86_64)
  • Power supply used | HP thin client supplied
  • SD card used | HP thin client 16gb ssd

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Clean install of dietpi, can’t get the usb wifi Archer TP-link AC600 T2u to work

Expected behaviour

Not quite sure if it should work without further action

Actual behaviour

Not working

Extra details

Hello,
can you tell us what you’ve tried to make it work?

1 Like

Plugged in and lsusb command recognises it.
2357:011e TP-link AC-600 wireless Realtek RTL8811AU (Archer T2u nano)
Tried install the drivers based on the instructions for Debian Ubuntu but rejected due to kernel headers not matching. I can’t see any which are appropriate for this distro though I am rather nooby to dietpi.

Tried enabling WiFi in Dietpi setup but doesn’t recognise the stick i.e. states no device.

TP-Link provides drivers on their homepage (https://www.tp-link.com/de/support/download/archer-t2u/), but only for kernel 5.0.
Since you are on Dietpi 8.16 I assume you are using kernel 6 already. But you could give it a try, the zip-file from TP-link comes also with a PDF for installation instructions.

1 Like

Kernel version depends on SBC/device used. OP missed to share kernel version, but it should be 5.10 as he is using x86 native PC

There we use standard Debian image and same kernel header should work as on other Debian x86 systems.

1 Like

Will try and get back.

Well that went badly. Tried putting a desktop on to make the install easier. That didn’t work, not sure what I messed up. Tried a fresh dietpi install and my usb sick won’t read. Ho hum. This might take some time.
In not sure the instructions on the tplink site have all the info I need…

You are correct, I am on 5.10.

Very weird, Balena Etcher USB sticks stopped working. Ended up having to use Ventoy to get the thing to boot the USB install stick .

OK, looking through the instructions here:

They are for a pi3. The instructions state that modifying the kernel will be different fir different pi s. I am guessing that is the case here?
Also the download location for the kernel downloads is deprecated.

Any idea how I go about updating the kernel module?

OK got it working eventually.

First off it was the wrong hardware I was looking for, so bonus idiot points for me. Should have been TP-link Archer AC600 T2u NANO.

This is not supported on Linux by TP-link. I used the guide here for Ubuntu.

Original github repo for the drivers is here which also had useful info.
https:// github[dot]com/aircrack-ng/rtl8812au

It helped when I worked out "(uname -r) should be replaced entirely by the kernel headers in the commands.

Thanks for the help, much appreciated. If you need more info just ask.

1 Like