Apt-get has failed

Odroid C2 running well with Plex server and pihole. Went to add Sonarr and got this:
Screen Shot 2017-10-06 at 11.47.07 PM.png
back at root I see these suggested steps:


I went through those steps, tried to install Sonarr again, and got the same error.

Sorry, I don’t have a Github account to place the error report there, I hope posting here is satisfactory.

is it a fresh install, or did you upgrade from dietpi v144 to v156 yet?

dietpi-update

It’s v156, tried dietpi-update, says it’s up to date. just tried installing Sonarr again, same error.

thanks for any help you can provide.

Hi,

Just tested on Odroid C2 with fresh image install, appears fine.

Issue may be related to your apt configuration, or software installed.

To debug, we’ll need to see the apt log, after you receive the error. Please upload the following file:

 /var/log/dietpi-software_apt.log

Once again, major :exclamation: newb alert :exclamation:

:thinking:

How do I get the apt log? I tried that code in the command line and it says not found, I found in another thread someone told to use the same but with ‘cat’ in front, so I did that and got this:

root@DietPi:~# cat /var/log/dietpi-software_apt.log
E: Unable to locate package nzbdrone

Is that all? obviously rather brief, so I expect not.

Thats the one :slight_smile:

Looks like the additional repo is not functioning. Lets try adding it manually:

dpkg --add-architecture armhf
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FDA5DFFC
echo -e "deb [arch=armhf] https://apt.sonarr.tv/ master main" > /etc/apt/sources.list.d/sonarr.list
apt-get update

Then lets try installing the package:

nzbdrone

If unsure of output, copy and paste the results of all of those commands, i’ll take a look.

ran the first part, then tried nzbdrone:

root@DietPi:~# nzbdrone
-bash: nzbdrone: command not found

Just for kicks I tried the Sonarr install again from dietpi-software and got the same error there.

I appreciate the help so much! I hope this isn’t a dead-end.

Hi,

Must be an issue with apt sources. We’ll need a bug report to investigate further.

Please run the following commands. This will fill the logs up with info we need before sending, and send a bug report:

dietpi-software install 114
dietpi-bugreport

Once sent, please reply with unique reference code.

Here ya go!

Reference CODE: 9f0321ed-289d-4e26-850b-a30a71dc0ee0-0

Update:

I see there is a DietPi update to v157, so I did the update and tried again. No luck.

...
Ign http://fuzon.co.uk jessie/main Translation-en                              
Fetched 197 kB in 21s (9,047 B/s)                                              
Reading package lists... Done
 [Info] Apt-get is processing, please wait...

E: Unable to locate package nzbdrone
 [Failed] The apt cache may be corrupt, apt mirror offline, or you have held broken packages. DietPi-Software will now exit.

 [Info] Apt Log:
E: Unable to locate package nzbdrone

So today I updated to v158 and thought I would try again. Same errors. But I noticed this while it was trying to install lots of “could not resolve ‘ftp.us.debian.org’”
Screen Shot 2017-11-14 at 2.00.17 AM.png
It occurred to me since there’s a .us. in that address that maybe it doesn’t like receiving requests from non-US IPs, and I am not currently in the US. So I turned a VPN on my router on to get a US IP, unfortunately still the same problem.



I also wanted to try installing Aria2 downloader tool. I got this error:
Screen Shot 2017-11-14 at 1.46.28 AM.png
And here’s the log:

root@DietPi:~# /var/log/dietpi-software_apt.log
/var/log/dietpi-software_apt.log: line 1: WARNING:: command not found
/var/log/dietpi-software_apt.log: line 2: libsqlite3-0: command not found
/var/log/dietpi-software_apt.log: line 3: E:: command not found
/var/log/dietpi-software_apt.log: line 5: E:: command not found
/var/log/dietpi-software_apt.log: line 7: E:: command not found
root@DietPi:~#

:frowning: