Anyone got Open Auto / Android Auto working

I’m trying to get this installed but am running into trouble compiling aasdk, ilclient. Aasdk I get it compiled with warnings but ilclient I haven’t.

Just wondering if anyone has it working.

Even if I don’t know the specific software title, you could have shared some error messages or logs. At least something we could have a look into.

Yea I figured someone would ask but before I went down that path I first wanted to see if anyone has even got it working.

ilclient libs come with Rasbian and are not a part of DietPi.

Our RPi ARMv6 image is Raspbian, and I guess those libs are actually not exclusive part of the Raspbian APT repository, but of and hence can be installed on all DietPi RPi images?

I think I got ilclient compiled, but I need aasdk compiled. Created an issue on github with the guy that is maintaining it. Hopefully it can be resolved.

maybe you could link the issue your created. Just as reference if someone else is looking for it.

I gave up actually. I think the problem is with the boost library. Apparently it might work with v1.70 but not sure how to downgrade that. I havent had a single reply to my issue created on github.

I believe Prime OS has an arm issue for the RPI4 (you will have to go thru the downloader options)
PrimeOS | Android for PC

And possibly Bliss OS (might be for x86 systems only)
[ROM][11][ARM64][Channel] BlissRoms 14 [OFFICIAL] | XDA Forums (

I didnt want to run an Android based OS. Specifically Linux as it gives me the ability to run other apps alongside. Thanks for the other two suggestions though!

Ah ok…never tried to run an android app on a dedicated linux distro
Might look into virtual such as proxmox…run linux in one VM and android on another

My apologies for the confusion

Just to track down what you are attempting…
Meet OpenAuto, an Android Auto emulator for Raspberry Pi |

Doing some digging…found this script that might assist in helping compile OpenAuto on a RPi3/RPi4
GitHub - DreamHazard/openauto-patched-installer: Installer for openauto on RPi which patches various issues with newer GooglePlayServices/touchscreen/device detection/compilation issues.

Wish I could help more

its ok, I didnt explain enough. Running DietPi on a Pi 4, trying to compile aasdk and its failing. End game was to run openauto/androidauto on linux.

You could try installing Waydroid, which can run an Android .apk in a container. I can’t say for certain how it will work on your setup, but it might be worth a shot. For Debian-based distros it’s as simple as adding the repo and installing through apt:

1 Like

Wow…that’s pretty cool!

Never seen that before

yea if it worked it would be impressive. lol. python3-gbinder has no install candidate. Manually compiling python3-gbinder fails too. Still googling…

It’s available as python3 package directly piwheels - gbinder-python

sudo pip3 install gbinder-python
root@DietPi:~# pip3 install gbinder-python
Looking in indexes:,
ERROR: Could not find a version that satisfies the requirement gbinder-python (from versions: none)
ERROR: No matching distribution found for gbinder-python

hmm…made progress I think…dont know if it will work since it requires Wayland

Anbox is the non-Wayland version of this project, although currently only the SNAP version is supported–I’m not sure if that is closer or further from what you are going for.