[Answered[ Plex update on diet

Hi all, hope someone can help me. I have tried several ways to update Plex but it doesn’t work.
I deinstalled it over dietpi-software and reinstalled still not newest version.
Plex tells me I have to update manually. the web installing way doesn’t work.
I have done apt update, apt upgrade
and still not updating
if I do apt-get install plexmediaserver -y I get the message that its already the newest version 1.13.0.5023
but Plex says there is a version 1.13.8.5395 available but I have to do it manually.
I have no idea how to do that. can someone help me pls?
thanks
mike

Thanks for your report.

Perhaps there was a delay between updating version infos on update server and APT repo packages. Just checked now and current version is 1.13.8.5395 now: http://dev2day.de/pms/dists/stretch/main/binary-armhf/Packages

Please retry apt-get -y upgrade now.

hi it didn’t work for me :frowning:

did you do the apt-get update first

In order to upgrade to latest it needs to update the databases from the servers

I always do mine under root [sudo su] (because it’s going to want to elevate anyway)

# apt update && apt upgrade -y

Does the update then rolls right into the upgrade if there are any packages updated

thanks WarHawk I did all you wrote and still. Plex is not updating. what am I doing wrong? :frowning:
I am using the Virtual Image and using it on my Mac with Parallels. that shouldn’t be the problem or?
thanks for the help.


Not sure how virtual on MAC works…

Should work just like any linux processor…but unsure

Maybe a developer will know more

hi, I’m having the same problem,

I have the Plex Version: 1.13.9.5456
And there is a new versión: 1.14.0.5470

But if I try to update doing this:

apt update && apt upgrade -y

Nothing occurs… only update tree dependencies, buy there is no new Plex version detected… maybe, is it because I have to add some repo? What an I do?

Also I have downloade this file: plexmediaserver-ros6-binaries-annapurna_1.14.0.5470-9d51fdfaa_armel.deb from de Plex Control Panel… what happens if I try to install manually? and how?

Thanks.

Just checked: https://dev2day.de/pms/dists/stretch/main/binary-armhf/Packages

  • Indeed the most current version in the repo is still 1.13.9

Note that the repo is 3rd party, since official Plex server is just available for x86 systems:

For this reason it might take a while until the newest version is up there. But if I see the latest upstream versions vs. how fast they were on repo, maximum a few days.

demerre
The control panel allows you to directly download a armel package? Could you follow is this came from the official download server: https://downloads.plex.tv/plex-media-server/… ?
Which device do you use? armel is usually ARMv6, e.g. RPi 1, while e.g. RPi2 and most other non-arm64 SBCs need armhf packages.
But if really the control panel offered this package, if might be chosen right already. I am just wondering why they do not offer to choose ARM packages from their website directly then :thinking:.

After verified that the package came from official download server and is right architecture for your SBC, then you can install via:

dpkg -i plexmediaserver-ros6-binaries-annapurna_1.14.0.5470-9d51fdfaa_armel.deb

There should be no issue with existing package. It should be just overwritten. And in case the repo has another update, it would overwrite the locally installed package again.

EDIT: Very strange, now the official download link is as well 1.13.9 :thinking: I though when I just looked some minutes ago it was 1.14…

  • So guys please be a bid patient until at least the version is really released on their official website…

EDIT2: Lol page reload, now shows 1.14 again… damn cant they just offer access to the bare download server directories so users can pick the version they need instead of relying on this unreliable automatic “latest version fetching” and download link generator… :roll_eyes:

MichaIng thnaks for your response.

Now I tried again:

apt update && apt upgrade -y

And it works perfectly. As you said, probably, now de repo (https://dev2day.de/pms/dists/stretch/main/binary-armhf/Packages) is updated.

I have a Raspberry Pi 2 B+, with a processor armv7l (32bit).

Thanks again for your information.

Ah okay, the repo was undated meanwhile. Quite fast, well maintained.