another Noob question: accessing Sonarr et all via browser

OK, so still greener than green with all this, so please provide any instructions on the assumption that I know nothing (which would be correct)

Have installed Sonarr, Radarr etc, and last night was able to access them via Chrome on my Mac and also Safari on my iPhone. I’ve since installed NordVPN client.

Since doing the NordVPN client (although the timing here could be coincidence…?) no web browser on my home network can connect with said applications. The browser page just hangs and then say it can’t connect. I’ve checked the Pi’s IP address on my router and it is the same as it was - 192.168…

Any ideas as to what might be causing this annoyance?

Many thanks in advance

you are using dietpi-vpn to connect to NordVPN? Or any other client?

Can you have a look. I guess it’s because of the killswitch being active

Joulinar how do I find out?


Pretty sure I downloaded the Nord client from Nord. I did check the Kill Switch and it was off

how did you activated NordVPN?

Pretty sure I downloaded the Nord client from Nord. I did check the Kill Switch and it was off, but I do recall a screen where I could select NordVPN… oh gosh, I’m feeling so out of my depth :frowning:

Perhaps I reflash the SD card and start again?

If I do what’s the best way to connect my Pi with my Nord VPN account?

well if you installed the NordVPN client, it could be removed. But you would need to know what you installed :wink:

Usually you could use dietpi-vpn script to connect to NordVPN. But I’m not sure if this will fix your issue. Personally I’m not using a VPN client and apps like Sonarr/Radarr

Just done this… there was no Nord software listed in the DietPi list, so not sure where I got it from previously

just use dietpi-vpn. No need to install something from software list

OK, so started from fresh.

Not connected VPN, but whatever browser I use is telling me that a connection to the IP Address that the Pi has can’t be made.

Totally flummoxed :frowning:

Verify that the server is running:
sudo ss -anp | grep arr; sudo ss -anp | grep mono
Verify that firewall is inactive
sudo iptables -t filter -c

typed in both of those commands, but not sure what the response it telling me :thinking:

If the killswitch is enabled, then yes, only SSH connections from LAN are possible currently. Without the killswitch, all LAN connections should be possible, as the LAN routes override the VPN routes. Remote connections, through the internet, aren’t possible in either case, as NordVPN does not support port forwarding.

Additionally to trendy’s suggested checks, we could also verify that the routes are as expected: ip r

EDIT: Please copy and paste the output of these commands here. You may mask all identifying info, of course.

Thanks for the help here. All appears to be OK now. Not sure what was causing that blip!

I guess you are using dietpi-vpn now, instead of the NordVPN client. :wink:

Not sure. I think me thinking inhale downloaded the Nord client was actually me downloading the OpenVPN ‘files’.

You have been so helpful in getting me set up… and slightly less scared of Terminal commands :sunglasses:.

Massive thanks

I was not able to access my local UIs when the killswitch was enabled. This was my confusion. I fixed by modifying: /var/lib/dietpi/dietpi-vpn/killswitch.rules. too include associated ports.

It assures that the system cannot bypass the VPN when the connection breaks unintentionally. It uses firewall rules to achieve this, which are created on intentional VPN connection (dietpi-vpn.service start) and removed only on intentional service/connection stop. With these rules the system is allowed to only send network packets through the VPN tunnel, to the VPN server (for reconnecting), to the LAN and SSH.

This is recommended when you use the VPN not (only) to connect to a remote LAN or unlock country limitations, but when you use the VPN to have your network connections private and encrypted from ISP etc.