Ampache doesn't install correctly - running DietPi v6.28.0 on RPi B (armv6l)

I’ve installed Ampache using dietpi-software without errors. But when i visit the page “http://ipaddress/ampache” I end up on a page that throws the following error:


You may have reached this page because Ampache was unable to load the required dependencies

Please visit the wiki for help

The url “http://ipaddress/ampache/test.php” also redirects to the above error page


I tried to verify the issue and installed it on my Demo VM. During installation I have seen some error message

  Failed to download dropbox/dropbox-sdk from source: Failed to clone via https, ssh protocols, aborting.

  Cloning into '/var/www/ampache/lib/vendor/dropbox/dropbox-sdk'...
  remote: Invalid username or password.
  fatal: Authentication failed for ''

  Cloning into '/var/www/ampache/lib/vendor/dropbox/dropbox-sdk'...
  error: cannot run ssh: No such file or directory
  fatal: unable to fork

    Now trying to download from dist
  - Installing dropbox/dropbox-sdk (v1.1.7): Downloading (failed)

  The "" file could not be downloaded (HTTP/1.1
  404 Not Found)

looks like some issues with source software package.
I tried to install it according ampache instructions and it fails at the same point during Composer steps. So it’s definitely something wrong at ampache side.

I created a bug report at ampache

Maybe the following details might help:

I enable logging under ampache. This is what the log file says:

2020-03-16 12:24:17 [ampache] (core.class) -> 'Gettext\Translations' not found!


no need to further investigate it at our side. This is an Ampache issue and would need to be fixed by Ampache developer.

You can follow this at GitHub


here you go with the small guide to implement the hacky workaround as discussed on the Ampache GitHub.

to work around the current ampache issue, you would need to adjust one DietPi file. As this is one of the core files and quite big, I would recommand to create a backup before. Changes on this file are needed only for this installation and would need to be rolled back afterwards

  1. lets do the backup
cp -p /DietPi/dietpi/dietpi-software /DietPi/dietpi/dietpi-software_save
  1. on this file you would need to change 3 sections
nano /DietPi/dietpi/dietpi-software
  1. search for the following line
G_RUN_CMD unzip -o $file ${target:+"$target"}

and change it into

G_RUN_CMD unzip -o $file -d "./ampache-123"
  1. search for the following line
Download_Install ''

and change it into

no_check_url=1 Download_Install ''
  1. search for the following 2 lines
mysql ampache < ampache.sql
rm ampache.sql

and change it into

mysql ampache < ./ampache-123/ampache.sql
rm ./ampache-123/ampache.sql
  1. if you already have Ampache installed, go to dietpi-software and uninstall it
  2. do a reboot
  3. and try to install Ampache again using dietpi-software

As dietpi-software is a huge file with more than 16.000 lines, I would recommend to use the search function within nano tool

This worked well! Thanks a lot

pls don’t forget to rollback the changes. Otherwise you could have issues on other software installation’s.