Amiberry fails to start

Creating a bug report/issue

Required Information

  • DietPi version | 8.15.2
  • Distro version | bullseye 0
  • Kernel version | Linux DietPi 6.1.19-v8+ #1637 SMP PREEMPT Tue Mar 14 11:11:47 GMT 2023 aarch64 GNU/Linux
  • SBC model | RPi 3 Model B (aarch64)
  • Power supply used | Official Raspberry Pi PSU 5.1v 2.5A
  • SD card used | SanDisk Micro SD - 16Gb

Additional Information (if applicable)

  • Software title | Amiberry
  • Was the software title installed freshly or updated/migrated? Installed fresh
  • Can this issue be replicated on a fresh installation of DietPi? Yes
    ← If you sent a “dietpi-bugreport”, please paste the ID here →

Steps to reproduce

  1. … Download the 8.15.2 image and burn to SD
  2. … Modify dietpi.txt to enable Wifi
  3. … Modify dietpi-wifi.txt to set SSID and password
  4. … Boot normally - follow first run process
  5. … Use dietpi-launcher to install OpenSSH and remove DropBear
  6. … Use dietpi-launcher to install Amiberry
  7. … Reboot, just in case
  8. … Log in as ‘root’
  9. … Type ‘systemctl start amiberry’

Expected behaviour

  • … I should see the Amiberry configuration page

Actual behaviour

  • … blank screen with cursor flashing in top-left corner

Extra details

  • … Ctrl-C drops back to the command prompt with no errors or other messages displayed

@MichaIng is this something you could help with?

Thanks for reporting. I actually just successfully tested in on RPi Zero W and faced the same when not raising the GPU memory split as suggested (but leaving it at 16 MiB). Did you raise it to the 76 MiB offered after the install?

Otherwise, after interrupting Amiberry (CTRL+C), can you check:

journalctl -u amiberry

And switch to TTY3 console via F3 key to see whether there are logs. We run Amiberry on TTY3 to not spam or mess with main console settings. Some older SDL version printed a respective character to the console for every key that was pressed while using Amiberry.
You can switch back to TTY1 via F1 key.

Ok, so this is odd. I had the GPU split set to 128Mb but I went back in and re-set it to 128Mb. It asked me to reboot and when it started back up, systemctl start amiberry worked as expected. Anyway, it’s working so thank you for the suggestion.

1 Like

Okay great that it works now.