Alsamixer equalizer not working

I have been using DietPi on a RPi3 with an Audiophonics ES9038Q2M DAC Hat for years. After deciding to upgrade my system to RPi4 the DAC Hat failed and I got a replacement, the new version board with the same name but USB-C connection and some other differences.

One thing I noticed is that with this RPi4 and the new DAC board I can’t use Alsamixer equalizer. I’m running Squeezelite, but that won’t run after boot saying is can’t find default output.

I already tried the solution of changing asound.conf as described in ALSA equalizer not working - #7 by MichaIng

After thr I can run Squeezelite manually by typing ‘squeezelite’ in the command line (or ‘squeezelite -o hw;0,0’, but restarting Squeezelite service (systemctl restart) gives same error as with reboot.

How can I make this work again?

(Running latest DietPi upgrade 8.12.1, but problem existed in previous version too.)

What do you mean by “Alsamixer equalizer”? You mean you enabled the ALSA equalizer plugin in dietpi-justboom (or manually) and use the dietpi-justboom menu or alsamixer -D eq to configure it?

Squeezelite doesn’t use that but the default ALSA output device, which should be visible in /etc/asound.conf.