After upgrade nzbget inactive and mariadb failed

Logged in to my pine64 running dietpi and noticed am upgrade waiting, never had an issue so I let it upgrade.
Only now nzbget is not loading and mariadb is failing

In Sudo dietpi-services nzbget shows as inactive the log doesnt show an error just starting and started… but it doesn’t

Mariadb (mariadb-server) shows as failed… I dont understand the log and dont see any issues… at work using a remote shell so I cant post it easierly.
Tbh I have no idea what mariadb is or does.

Tried removing and reinstalling both but no go.

I have hardly any knowledge of linux so I am kinda stuck

Can I roll back the upgrade of diet pi (nzbget worked fine then)?
What’s the difference between inactive and failed? Can I make it active?

Seems my network drive usually mounted via fstab is not auto mounting…so nzbget wont load…

A place to start atleast…though it auto mounted just fine before the upgrade…

Mental note never upgrade dietpi unless its broke lol

Fixed due to

changing the fstab options that have worked perfectly for over a year solved it…no idea why it suddenly stopped working…

mariadb still failing…still no idea what it is…why its failing …but things are working ok with out it shrug

pls try to start MariaDB as follow

systemctl start mariadb.service

Once done pls past output of following

journalctl -u mariadb.service

dietpi@DietPi:~$ sudo journalctl -u mariadb.service
– Logs begin at Sat 2020-01-04 21:58:48 GMT, end at Sun 2020-01-05 12:56:59 GMT. --Jan 04 21:59:37 DietPi systemd[1]: Starting MariaDB 10.1.41 database server…
Jan 04 21:59:37 DietPi mysqld[1243]: 2020-01-04 21:59:37 281473407926272 [Note] /usr/sbin/mysqld (mysqld 10.1.41-MariaDB-0+deb9u1) starting as process 1243 …
Jan 04 22:01:07 DietPi systemd[1]: mariadb.service: Start operation timed ou
t. Terminating.
Jan 04 22:01:49 DietPi systemd[1]: mariadb.service: Main process exited, cod
e=exited, status=1/FAILURE
Jan 04 22:01:49 DietPi systemd[1]: Failed to start MariaDB 10.1.41 database
Jan 04 22:01:49 DietPi systemd[1]: mariadb.service: Unit entered failed stat
Jan 04 22:01:49 DietPi systemd[1]: mariadb.service: Failed with result ‘time
Jan 05 12:55:22 DietPi systemd[1]: Starting MariaDB 10.1.41 database server…
Jan 05 12:55:23 DietPi mysqld[23559]: 2020-01-05 12:55:23 281473172647936 [Note] /usr/sbin/mysqld (mysqld 10.1.41-MariaDB-0+deb9u1) starting as process 23559 …
Jan 05 12:56:53 DietPi systemd[1]: mariadb.service: Start operation timed ou
t. Terminating.

The first command just made it hang. Still no idea what mariadb even does. I get it’s a database thingy (tech term) but everything seems to be working with out issue even with it failed

MariaDB is a database server, often used by web applications, like Nextcloud and others to store settings and data. You can check which of your installed programs use it:
dietpi-software list | grep ’ =2 ’

This lists all programs installed via dietpi-software. Those which use MariaDB have some +mariadb on the line. If it is really not used by anything, you could purge it: apt purge mariadb-server && G_AGA
Take care that the first command does not purge anything you require and might depend on the MariaDB server package.

Since DietPi v6.28 you can also uninstall it via dietpi-software uninstall 88, on earlier versions this failed if the service start fails since it tried to do a database backup which required it to start first.

To better debug MariaDB start-up issues:

systemctl restart mariadb # This hangs for 90 seconds
cat /var/log/mysql/error.log


I found this comment on Maria DB forum. Maybe it’s something that could be applicable for you as well

as well as