After update of Dietpi Wireguard connection is no longer working

I’ll write in here too :wink:

I also made an update today from Dietpi and since then my Wireguard connection no longer wants either

}dietpi@DietPi:~$ wg-quick up wg0
wg-quick: `wg0' already exists
dietpi@DietPi:~$ wg-quick down wg0
wg-quick: `wg0' is not a WireGuard interface
root@DietPi:/home/dietpi# journalctl -u wg-quick*
-- Journal begins at Wed 2023-08-02 22:00:33 BST, ends at Wed 2023-08-02 22:01:01 BST. --
Aug 02 22:00:34 DietPi systemd[1]: Starting WireGuard via wg-quick(8) for wg0...
Aug 02 22:00:34 DietPi wg-quick[475]: wg-quick: `wg0' already exists
Aug 02 22:00:34 DietPi systemd[1]: wg-quick@wg0.service: Main process exited, code=exited, status=1/FAILURE
Aug 02 22:00:34 DietPi systemd[1]: wg-quick@wg0.service: Failed with result 'exit-code'.
Aug 02 22:00:34 DietPi systemd[1]: Failed to start WireGuard via wg-quick(8) for wg0.

Do you have any ideas … unfortunately I’m not the Linux cracker :smiley:

Did you tried to reboot your system?

yes without success

pls reboot your system and post following afterwards

journalctl -u wg-quick*

the excerpt above was after the reboot … buddy just accepted it, there was no curl and nothing more, he sorted it out again somehow

But please don’t ask me how

Something didn’t go well with the update, although it went through clean

The update did not cause any issues on my prod system and Wireguard is working fine still. Pls can you share the requested information. As well pls fill out the trouble shooting template.


  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

As I said, the problem was fixed, a colleague knows his stuff very well and fixed it… can therefore be closed Thanks anyway

it would be good if you could share the solution. This might be helpful for others.

Since I’m not very familiar with Linux and a colleague of mine did it, I can’t say much about it … his statement was “there were a few things that didn’t fit”

would be good to know what did not fit. Because our update did not changed / touched Wireguard at all.