Adguard/Unbound (using Adguard DHCP server)


When I manually point a device to AdGuard it (and Unbound), it works perfectly).
When I switch off DHCP on my router (and switch it on in AdGaurd), I lose internet everywhere.

In the docs, there is a reference to DiePi needing to select a static DNS from the list, but shouldn’t that simply be Unbound’s address?

My Pi has a static IP.


If you have a windows box, have I restarted and check what IP address you got assigned from AGH DHCP server.


I have a Mac. After setting up DHCP, I restarted it and it gave me the correct IP of my Pi (not my router).

sorry, I may have misunderstood you. ADH gave me the IP which was within the range of 101-200 that I set it up to give.

My DietPi’s IP is (static).

edit: and ADH showed stats from my Mac and everything appeared to be working (except internet access).

Is unbound up and running fine?

journalctl -u unbound


because it’s not a small effort to keep swapping over (restarting the router, my Mac and most of my devices), I uninstalled ADH/Unbound, reinstalled and tried again and it is working fine now.

No clue why.


Did you checked Unbound status before? Maybe it was not running fine. Anyway, it’s solved now.

I do appreciate your help though! :smile:

…so are you suggesting that I would still have had internet access when my router was handling DHCP and my Mac was manually pointed to ADH but Unbound wasn’t running? i.e. Unbound is only a factor when ADH is also managing DHCP?

Doesn’t matter how DHCP is done. AGH will use Unbound as upstream DNS as long as it is configured. But maybe we misunderstood. You could have checked where and what is failing. But we will never find out now, as you fixed it by re-installation of AGH/Unbound. :wink:

understood and thanks :smile: