Adafruit IO

Would it be possible to put together something to support and enable Adafruit IO?

Quite a handy method (combined with IFTTT and a bit of Python) to control various other servers and IoT stuff via API’s. For example I’m using it to trigger my Volumio radio via IFTTT (details here) and would have liked to run the IO server bit on my DietPi general server.

I did try installing it on the machine manually (it installs via pip normally) and it failed due to some mismatched dependency versions, so in the end had to set it up on a seperate Pi Zero which is not quite what I wanted.

Would a software option to support this be possible?

Which dependency failed?
If you can run the server on Raspbian I don’t see the reason why it wouldn’t run on DietPi as well.

I think I might have had confusion between the python2 and python3 pip installs. I’ve just tried it again from scratch with an install of python3-pip and this time it’s worked.

I forget offhand which dependency was messing up - it was requesting an upgrade of something and failed to do that. I didn’t want to push things too far in case I broke the whole install, but now it all seems to be working fine.

yep python2 pip and python3 pip3 are 2 different thinks. They can easily exist next to each other on the same system.