Adafruit 3.5 tft

Wanted to throw out a request for the adafruit 3.5 tft display. Spent my weekend trying to get it to run with a variety of install options but always came up empty.

Dietpi is very usable without the feature but it sure would be cool to have it all display on the tft.


Did you try it with RPi or which device?

Ya I tried to get it going for the Raspberry Pi.

Add me to the list, in my case I use the 2.8" TFT from Adafruit with my Raspberry Pi 3B+. I managed to get through the Adafruit driver install by doing the following as root:

  • First I went through the script and replaced references to “/home/pi” with “/home/dietpi

  • Next I installed setuptools:
sudo pip install -U setuptools

  • Then I installed python-dev:
sudo apt-get install python-dev

  • When I started running into issues during the PIP install of the driver, I was able to actually get through it with no problems by first installing these common dependencies:
sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

This allowed me to get through the install script without any errors. However, when I reboot, I’m still not seeing anything on the TFT.

Any pointers on how to get this resolved without having to switch away from Dietpi? I really love this OS.

Hi I am having the same issue.

I have run the TFT install script the when I reboot, it is just not showing on the TFT screen. Screen is on but completely blank. Anyone figure this one out?

Add me to the list. Got an RPI B up and running on Dietpi this AM. Cloned the git from Waveshare and ran the driver install but no love.

Okay found the script:

Outdated and adds forcefully an outdated Raspbian mirrordirector that is changes by RPi packages again. Tailored for Raspbian. Strange that it does not add the build requirements then. I’ll see if I find time to contribute to it to make it better compatible with non standard Raspbian distros. If anyone wants to help, is welcome of course :slight_smile:.

Ahh btw is this dtoverlay “pitft35-resistive”, shipped with RPi firmware, not already functional?

See bottom of this post:

I’m able to get this working with a Pi Zero and Adafruit Mini PiTFT. Here are the steps I followed:

  1. Download the Adafruit script as mentioned here:
cd ~
git clone
cd Raspberry-Pi-Installer-Scripts
chmod +x
  1. After following all the steps below, run the script with the homedir parameter: ./ -u /home/dietpi
  2. Do a apt-get install setuptools
  3. Do apt-get install wheel
  4. Go to dietpi-software > software additional software > Python Pip
    (I also remember running apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk from jackspace above). From dietpi-config I have also enabled I2C and in the Display Options clicked on LCD panel and selected the waveshare32 option.
  5. Then I got an error about gcc-arm-linux-gnueabihf. Did apt-get install gcc-arm-linux-gnueabihf
  6. After that I got a make error. Did sudo apt-get install build-essential
  7. Do apt-get install raspi-config
  8. Do a adduser pi and set its password
  9. Make sure raspi-config is working fine
  10. Got an error related to rc.local. created /etc/rc.local, made it an executable chmod +x /etc/rc.local, edited it and added following lines:
#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.

# Print the IP address
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
printf "My IP address is %s\n" "$_IP"

exit 0
  1. Start rc.local service: systemctl start rc-local and make sure that it is running: systemctl status rc-local
  2. Finally run ./ -u /home/dietpi
  3. If everything is successful, script asks for a reboot, and terminal display is shown on TFT

Thx for sharing your solution. Much appreciated.

Running installer as above fails with obsolete dependencies.

Had to use the following now after full install of Dietpi latest (7.5.2)

My 2. is a bit different though.

sudo python3 --display=35r --rotation=90 --install-type=fbcp (basically a non-interractive install)


Back working fine:

Adafruit 3,5 TFT
PHAD Alternative pihole display

Need to do

Thx for sharing your solution. Much appreciated.

You’re Welcome

Put it here so I can find when reinstalling :rofl: