A 2nd USB drive isn't automounted at reboot, is configured in drive-manager

Creating a bug report/issue

Required Information

  • DietPi version | `G_DIETPI_VERSION_CORE=8
  • Distro version | `bullseye 1
  • Kernel version | 5.15.84+ #1613 Thu Jan 5 11:58:09 GMT 2023 armv6l GNU/Linux
  • SBC model | RPi B (armv6l) (512Mb Original Pi B !)
  • Power supply used | (White Official Pi PSU
  • SD card used | Amazon Basics (surprisingly fast)

This could be ignorance on my part, so this isn’t so much as a bug report as asking for advice.

I’m using Dietpi on an original Pi Model B with 512 ram. Originally configured with userdata on a 128MB USB drive.

I recently added a 2nd USB drive, configured this in dietpi-drive manager.

All worked well.

Upon reboot, the drive isn’t mounted (the devices /dev/sda and /dev/sdb both exist)

When I go into dietpi-drivemanager, it detects and auto mounts the drive. I can then quit out of drive manager and now use the drive.

This happens on each reboot, the 2nd USB drive isn’t auto mounted.

I have a vague memory of this happening to me some time ago, also on dietpi.

Have I just missed something to make it automount?


can you share following

cat /etc/fstab

I rebooted yesterday and it worked fine this time without having made any changes. Previously, the 2nd USB drive didn’t auto mount. (Going into dietpi-drive_manager and then exiting would resolve this)


Here’s the etc/fstab :

# You can use "dietpi-drive_manager" to setup mounts.
# NB: It overwrites and re-creates physical drive mount entries on use.

tmpfs /tmp tmpfs size=1024M,noatime,lazytime,nodev,nosuid,mode=1777
tmpfs /var/log tmpfs size=50M,noatime,lazytime,nodev,nosuid,mode=1777

# MISC: ecryptfs, vboxsf, glusterfs, mergerfs, bind, Btrfs subvolume

/var/swap none swap sw

PARTUUID=4824bc19-02 / ext4 noatime,lazytime,rw 0 1
PARTUUID=4824bc19-01 /boot vfat noatime,lazytime,rw 0 2
UUID=6377279d-8a7f-46ef-8dc0-9b163807e319 /mnt/6377279d-8a7f-46ef-8dc0-9b163807e319 ext4 noatime,lazytime,rw,nofail,noauto,x-systemd.automount
UUID=6a21d0c5-5520-42f6-92e3-6119aa95dff5 /mnt/6a21d0c5-5520-42f6-92e3-6119aa95dff5 ext4 noatime,lazytime,rw,nofail,noauto,x-systemd.automount

That looks all good.

Just to avoid a misunderstanding, drives are not mounted during boot process directly. They will be mounted as soon as someone or a process is going to access them. Means it could look like, they are not mounted but the will once going to access them.

Ah, thank you. That is likely to be my misunderstanding.

I reboot, I log in, and df -h was only showing one drive mounted.