8.10.2 version upgrade from 8.9.2 works on everything but my Pi Zero Pi-Hole

Creating a bug report/issue

Required Information

  • DietPi version |

  • Distro version | bullseye 1

  • Kernel version |
    Linux Pi-Hole-1 5.15.61+ #1579 Fri Aug 26 11:08:59 BST 2022 armv6l GNU/Linux

  • SBC model | RPi Zero (armv61)

  • Power supply used | 5V 2A

  • SD card used SanDisk ultra

Additional Information (if applicable)

this is affecting all update attempts on the RasPi zero

Steps to reproduce

  1. … have DietPi 8.9.2 installed on a RasPi Zero
  2. …try to upgrade to 9.10.2

Expected behaviour

  • … it should update

Actual behaviour

  • … It will not successfully run an ‘apt update’ or ‘dietpi-update’

Extra details

  • I was able to update 8.9.2 to 8.10.2 on a couple Raspi 2, a RasPi 3B+, a couple Pine64, a couple Odroid, and a NanoPi but the RasPi Pi Zero fails at connecting to the first repository.
    Err:1 Index of /debian/ bullseye InRelease
    Could not connect to packages.azlux.fr:80 ( - connect (111: Connection refused)
    Get:2 Index of /debian bullseye InRelease [116 kB]
    Get:3 Index of /debian bullseye-updates InRelease [44.1 kB]
    Get:4 https://deb.debian.org/debian-security bullseye-security InRelease [48.4 kB]
    Get:5 Index of /debian bullseye-backports InRelease [49.0 kB]
    Hit:6 Index of /debian bullseye InRelease
    I have tried changing the source.list and the APT mirror in Dietpi-Config but no matter what it tries to connect to packages.azlux.fr and fails with connection refused. I can manually go to the site in a browser with no issues. Now I had previously been able to do updates, but honestly when it works I wasn’t paying attention to the repositories. I only first noticed a problem when trying to update and now no update works. So I know its probably not the 8.10.2 cause its not getting installed, but why is the 8.9.2 suddenly having problems with the packages.azlux.fr when the site appears to be functional. I have tried changing everything I can think of…but I am not that bright cause nothing is doing anything different, Thanks in advance

nevermind…it was an Id10t error for sure. I sure didn’t think of it but found another post to make me figure it out.

1 Like

At least you figured where the issue was located :wink: