2nd day help - ProFTP

Hi guys,

It’s my second day with an Odroid XU4 and I’m having a little trouble figuring things out.

What I have done so far:
Installed dietpi
Installed ProFTP
Installed Transmission - haven’t tried doing anything with it yet.
Installed Kodi - rebooted Dietpi and it boots to Kodi as desired. Haven’t done anything with Kodi yet as I have no media on my device.
Plugged in a USB 1TB WD Red 2.5" NAS drive and enclosure to one of the USB 3.0 ports
Plugged in a wireless keyboard dongle to the USB 2.0 port
Connected the vie CAT5e patch cable from ethernet port to my router
Mounted and formatted my hard drive in EXT4 format
Adjusted the settings for ProFTP to access my external hard drive by default
Connected to my Odroid via SSH using Dropbear SSH
Connected to ProFTP using my browser, also connected via FileZilla

What I am struggling with:
Using FileZilla I am denied access to transfer filed from my PC to my Odroid, I am also denied access to create new subdirectories. How do you set up new users / change permissions? This needs to be in baby steps and plain English. I’m only on day 2 with a Linux based system.

I am unable to connect to ProFTP using root, I can only connect via the dietpi username

On my main command prompt screen I tried accessing ProFTP configuration logged in as root. I typed:
-bash: /etc/proftpd/proftpd.conf: Permission denied

Questions about Dietpi

Is there a command to shutdown the device?

Is there a command to restart the device?

Is there a command to log the current user out? (i’ve been restarting the device)

Is there a command to login with a new user without restarting the device?

Any help with these issues would be greatly appreciated.

Are you using standard FTP or SCP?

If SCP you can’t use Dropbear, you have to install OpenSSH

To access the proftp directory, you need to cd into the directory

cd /etc/proftpd

Using DietPi-Software I selected ProFTP as my filesystem, it states that is uses FTP protocol, dropbear is selected as my SSH Server. I have confirmed that my drive is mounted and set to read/write. Not sure what I’m supposed to do after I type in cd /etc/proftpd. The only thing showing in my drive is a lost+found folder.


should show you a config file or something in that directory

nano is a program used to edit file (so is vi and vim)…but it will have to be done under root (dangerous to run as root as a user) or sudo (less dangerous but you elevate to root privileges so you can break alot of stuff…be careful running stuff as elevated user)

Have you setup a user to be able to ftp into the server?


in the directions they use vi (another linux “shell text editor”)

Hopefully that will help

It is always good to create a user that you can log in to your linux machine as a “user” rather than administrator (root) but that has sudo capabilities (the ability to elevate to run root commands)


I adjusted some folder permissions and have been doing everything as root up until now. I was able to find and edit the config file using nano so the good news is I’m learning stuff but now I can’t even get into my FTP server (this was before I edited the .conf and has persisted after) , whereas yesterday I could get in and read but couldn’t write so I think I’m going to just wipe everything and start from scratch. Thank a bunch for the help.

So I re-flashed dietpi to my card and went through the installation procedure again. I followed these exact steps:

Reinstalled Diet Pi
Mounted my external harddrive, reformated it to wipe all date ext4 format
Created a new user with sudo priv, tested to ensure new user has sudo priv
Installed ProFTP
edited the proftpd.conf file to change server name and default mount location.
Using a Google Chrome on my Windows 7 PC I accessed my ProFTP server. It would not let me access it using root as my username, i used my new usr with sudo priv to access. The only folder in the drive was a lost+found folder
I now accessed the same server using my sudo user via FileZilla.
I attempted to create a new directory using FileZilla, I got an error 550 New directory: Permission denied
I attempted to move a media file to my ProFTP server and got the same error.

So at this point my questions are two fold:

  1. Who is denying me permission? Is it FileZilla? Is it ProFTP? or is it DietPi?
  2. How to I change it so I can transfer files to my ProFTP server?

Edit #2
I was able to resolve these issues with
sudo chmod -R 0775 /mnt/drive1/
sudo chown -R username /mnt/drive1/
Files are now transferring at a whopping 4MB/s, this seems slow, is there any way to speed this up?

did you uncomment the line

DefaultRoot : Uncomment this line to restrict users with their home folders.

remove the # in front of it, restart proftp

use user priv to log in
make sure the /home/priv directories are owned by that user

ls -lah

(that is list -long listing [show details], all, human readable )
I usually add that as an alias in my .bashrc file so when I type ll it automatically types that entry for me…a quick directory listing quick key setup…but that’s personal preference

if they do not say priv:priv you will need to

sudo chown -R priv:priv /home/priv

That says as “administrator” change the owner of the entire directory (and everything in it recursively) to priv:priv

Edit the code to reflect the mount directory of the external drive where your data is held…if you used dietpi-drivemanager it should be under /mnt/something something

I don’t have a proftp server setup on my systems…I use SCP and filezilla, maybe a developer or someone more in the know will showup and help with the problem

So I ran into another problem. After a while my proftp server kicks me off and doesn’t let me log back on. If I wait for a while (half hour or so) it lets me get back on but then tells me the directory is read only (after I had been previously writing to it with the same user.)