24 bit wav files crackle and static - Justboom and MPD settings on Tinkerboard


I’m using a Tinkerboard with Minimserver and Upmpdcli. It’s a great stripped down music server because of Dietpi. To get this set up, I have developed limited Linux skills, but am really enjoying the learning curve. :thinking: :slight_smile:

Could I ask Fourdee and the community to advise on the Dietpi-config>audio settings. I’m hoping here to get troubleshooting advice, because I’m getting constant crackle and static on 24bit wav flies. 16 bit files play fine (and sound really good). I’ve googled the problem, and understand it’s probably a latency and/or bandwidth issue - either in ALSA settings or the USB hub. That research has been here, other forums, and guides. Right now, I’m trying to reason through where to start.

First, is anyone else able to tell whether the standard MPD version in Dietpi is much the same as, or quite different from the MPD compiled by the Upmpdcli author? Basically, is there any conflict between Dietpi’s MPD version, and the needs of Upmpdcli?

Second, are the Justboom and MPD options for Dietpi on Tinkerboard capable of being set up for clean 24 bit playback? I have experimented with setting “24 bit”, and this does not fix the issue. If I set Dietpi MPD at “32 bit” my control app becomes unstable and crashes.

Third, is it possible to get the Moode 384 kHz kernel onto the Tinkerboard? I see from an old thread that it’s already a working solution for distorted 24 bit playback on Raspberrypi.

Thanks in advance. Any advice on where to look would be really appreciated.