158 to 159 error in dietpi-software

Hi there,

first i love this product… so glad i found it… its made the Pi come alive.

i notice when i logged in that there was an upgrade available from 158 to 159… so i did this rebooted and all seemed ok.

However when i run dietpi-software i am now getting the following error.

/dietpi-software: line 16201: unexpected EOF while looking for matching `"’

checking this file and it seems the script has been corrupted and the rest of this script as been lost… it just ends at line 16201


if (( ${aSOFTWARE_INSTALL_STATE[1]} == 1 )); then

WHIP_TITLE=‘Samba Client - Setup Now?’
WHIP_QUESTION=‘Samba Client can be setup and configured by using DietPi-Config. Would you like to go there now? \n\n- Once completed, exit DietPi-Config to resume setup.’
whiptail --title “$WHIP_TITLE” --yesno "$WHIP_QUESTI

is there a copy i can get to replace this currupted version?




Many thanks k-plan. that worked a treat.


This could be due to system instability/filesystem corruptions on the device. However, we’ll add a force disk sync after the update for v160 as failsafe.