1. Raspberry pi zero cannot select OpenGL as resolution 2. Play games with Raspberry pi zero?

In dietpi-config > display options > Resolution, i try to select options for both vc4-kms-v3d and vc4-fkms-v3d.

The options are available, but i cannot select them. However, i can select other resolution options, and after i reboot, new changes will apply. I am using Raspberry pi zero with no overclock (1000 mHz).

I am trying to play games on Dietpie without installing Retropie.
Currently i try to run NES Famicom emulator (fceux) in Dietpie using Pi Zero, the game run but not very smooth. I had turn off all the video filterings options. The best i can get is 58+ fps with some lag.

Another emulator i tried is Visualboyadvance, but i am only getting 7+ fps so it is totally unplayable. But from Youtube, there are many videos showing games (Nes / GBA) emulate with Raspberry pi zero without problems.

Is it because of the OpenGL issue? I tried MineCraft-pi version, it run without issue. Or is it because i must use Retropie?

There are currently known issues with the latest RPi kernel/firmware version and VC4.
See: https://github.com/MichaIng/DietPi/issues/2935#issuecomment-506389899
And: https://github.com/MichaIng/DietPi/issues/2935#issuecomment-508955357

Which errors shows up when you select a VC4 option or what happens exactly?

No error showed up. After i select a VC4 option, my resolution is still the same. However, when i select other non-VC4 option, my resolution will changed at next reboot.

I tried install and run neverball, the audio runs, but no video showed up.
Or am i need to install an OpenGL driver for raspberry pi zero?

After some adjustment and fine tune, I manage to run fceux (NES Emulator) on Dietpi without any lag. Gamepad also work out of the box.

However, all 3d games… GBA, Neverball etc… cannot run. But i can run Minecraft Pi edition perfectly on Raspberry Pi Zero. The 3d graphic for Minecraft Pi run without any lag. But for neverball, only audio sound is heard, no graphic at all.

Really strange, is there a way or driver to enable the 3d graphic for all games?

Refer here: https://www.youtube.com/watch?v=O-WeW61yFdc

And here: https://www.raspberrypi.org/forums/viewtopic.php?t=166495

before modification, neverball will not run.
Run neverball in usr/Game/neverball, the window opened, but no visual.

Now, add


in config.txt


Test run Graphic=>glxgear, you will noticed the framerate improved significantly.

Run neverball again, you will noticed the game run successfully.

Try to run fceux NES emulator, the framerate also improved significantly. Now I can enable the opengl option.

So far I only can figured this out to enable openGL on Raspberry pi zero. If anyone knows how to improve more on this issue, pls let me know. Thank you.

*Above is run on an overclocked Raspberry pi zero to 1150mhz, overvolt=8, force_turbo=1, initial_turbo=30

Thanks for providing.

Also the newest firmware updates have fixed some VC4/OpenGL related issues.
So besides the above what might further help is apt full-upgrade.